Read the docs

Cross-site request forgery in Jenkins Fortify on Demand Uploader Plugin

Priority LOW 32CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

A cross-site request forgery vulnerability in Jenkins Fortify on Demand Uploader Plugin 3.0.10 and earlier allows attackers to initiate a connection to an attacker-specified server.

Why it matters now

EPSS 0.01339 71st percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:fortify-on-demand-uploader (Maven): 3.0.11

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Fortify on Demand Uploader Pluginup to 3.0.10—No fix listedCNA
—org.jenkins-ci.plugins:fortify-on-demand-uploader (Maven)before 3.0.113.0.11Patch availableGHSA-7jcx-j6gv-m4hf
  • Jenkins Fortify on Demand Uploader Plugin VendorJenkins Affected up to 3.0.10 Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:fortify-on-demand-uploader (Maven) Vendor— Affected before 3.0.11 Fixed in 3.0.11 Patch available GHSA-7jcx-j6gv-m4hf

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:fortify_on_demand_uploader:*:*:*:*:*:jenkins:*:*up to 3.0.10VulnerableJenkins
  • cpe:2.3:a:jenkins:fortify_on_demand_uploader:*:*:*:*:*:jenkins:*:* Versions up to 3.0.10 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-7jcx-j6gv-m4hf org.jenkins-ci.plugins:fortify-on-demand-uploader (Maven) Fixed in 3.0.11 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-1003046
  2. 2026-10-03 Alias added: GHSA-7jcx-j6gv-m4hf

References

  • TI-2019-15892 Missing authorization in Jenkins Fortify on Demand Uploader Plugin CVSS 3.1MEDIUM 6.5

Sources