Read the docs

Cross-site request forgery in Jenkins Nomad Plugin

Priority LOW 31CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

A cross-site request forgery vulnerability in Jenkins Nomad Plugin in the NomadCloud.DescriptorImpl#doTestConnection form validation method allows attackers to initiate a connection to an attacker-specified server.

Why it matters now

EPSS 0.01296 70th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:nomad (Maven): 0.5.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Nomad Pluginall versions as of 2019-04-03—No fix listedCNA
—org.jenkins-ci.plugins:nomad (Maven)before 0.5.10.5.1Patch availableGHSA-5q63-jvc9-qphv
  • Jenkins Nomad Plugin VendorJenkins Affected all versions as of 2019-04-03 Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:nomad (Maven) Vendor— Affected before 0.5.1 Fixed in 0.5.1 Patch available GHSA-5q63-jvc9-qphv

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:nomad:*:*:*:*:*:jenkins:*:*all versionsVulnerableJenkins
  • cpe:2.3:a:jenkins:nomad:*:*:*:*:*:jenkins:*:* Versions all versions Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-5q63-jvc9-qphv org.jenkins-ci.plugins:nomad (Maven) Fixed in 0.5.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-1003092
  2. 2026-10-03 Alias added: GHSA-5q63-jvc9-qphv

References

  • TI-2019-15938 Missing authorization in Jenkins Nomad Plugin CVSS 3.1MEDIUM 6.5
  • TI-2021-04761 Insufficiently protected credentials in Jenkins Nomad Plugin CVSS 3.1MEDIUM 5.5

Sources