Insufficiently protected credentials in Jenkins TestFairy Plugin
Priority LOW 32CWE-522Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-522.
Summary
Jenkins TestFairy Plugin stores credentials unencrypted in job config.xml files on the Jenkins master where they can be viewed by users with Extended Read permission, or access to the master file system.
Why it matters now
EPSS 0.01645 76th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:TestFairy (Maven): 4.17.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins TestFairy Plugin | all versions as of 2019-04-03 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:TestFairy (Maven) | before 4.17.2 | 4.17.2 | Patch available | GHSA-ffv8-x822-fx73 |
- Jenkins TestFairy Plugin VendorJenkins Affected all versions as of 2019-04-03 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:TestFairy (Maven) Vendor— Affected before 4.17.2 Fixed in 4.17.2 Patch available GHSA-ffv8-x822-fx73
Remediation
- Fix · GHSA-ffv8-x822-fx73 org.jenkins-ci.plugins:TestFairy (Maven) Fixed in 4.17.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-1003096
- 2026-10-03 Alias added: GHSA-ffv8-x822-fx73
References
Sources
- CVE-2019-1003096 · CVE Program
- CVE-2019-1003096 · NVD
- FIRST EPSS
- GHSA-ffv8-x822-fx73 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences