Infinite loop in SecDev scapy
Priority LOW 38CWE-835Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-835.
Summary
scapy 2.4.0 is affected by: Denial of Service. The impact is: infinite loop, resource consumption and program unresponsive. The component is: _RADIUSAttrPacketListField.getfield(self..). The attack vector is: over the network or in a pcap. both work.
Why it matters now
EPSS 0.02791 86th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed scapy (PyPI): 2.4.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SecDev | scapy | 2.4.0 | — | No fix listed | CNA |
| — | scapy (PyPI) | 2.4-rc1 to before 2.4.1 | 2.4.1 | Patch available | GHSA-mpf2-q34c-fc6j |
- scapy VendorSecDev Affected 2.4.0 Fixed in — No fix listed CNA
- scapy (PyPI) Vendor— Affected 2.4-rc1 to before 2.4.1 Fixed in 2.4.1 Patch available GHSA-mpf2-q34c-fc6j
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:scapy:scapy:2.4.0:*:*:*:*:*:*:* | 2.4.0 | Vulnerable | Scapy |
| cpe:2.3:o:fedoraproject:fedora:29:*:*:*:*:*:*:* | 29 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:* | 30 | Vulnerable | Fedoraproject |
- cpe:2.3:a:scapy:scapy:2.4.0:*:*:*:*:*:*:* Versions 2.4.0 Vulnerable ·Scapy
- cpe:2.3:o:fedoraproject:fedora:29:*:*:*:*:*:*:* Versions 29 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:* Versions 30 Vulnerable ·Fedoraproject
Remediation
- Fix · GHSA-mpf2-q34c-fc6j scapy (PyPI) Fixed in 2.4.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2019-1010142
- 2026-10-03 Alias added: GHSA-mpf2-q34c-fc6j
References
Patch 2
Advisory 3
Other 5
- https://github.com/pypa/advisory-database/tree/main/vulns/scapy/PYSEC-2019-120.yaml
- https://github.com/secdev/scapy
- https://lists.fedoraproject.org/archives/list/[email protected]/message/42NRPMC3NS2QVFNIXYP6WV2T3LMLLY7E
- https://lists.fedoraproject.org/archives/list/[email protected]/message/T46XW4S5BCA3VV3JT3C5Q6LBEXSIACLN
- https://www.imperva.com/blog/scapy-sploit-python-network-tool-is-vulnerable-to-denial-of-service-dos-attack-cve-pending
Sources
- CVE-2019-1010142 · CVE Program
- CVE-2019-1010142 · NVD
- FIRST EPSS
- GHSA-mpf2-q34c-fc6j · GitHub Advisory Database · CC BY 4.0
- CVE-2019-1010142 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences