Uncontrolled recursion in serde_yaml
Priority LOW 31CWE-674Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-674.
Summary
serde serde_yaml 0.6.0 to 0.8.3 is affected by: Uncontrolled Recursion. The impact is: Denial of service by aborting. The component is: from_* functions (all deserialization functions). The attack vector is: Parsing a malicious YAML file. The fixed version is: 0.8.4 and later.
Why it matters now
EPSS 0.01083 65th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| serde | serde_yaml | 0.6.0 to 0.8.3 [fixed: 0.8.4 and later] | — | No fix listed | CNA |
- serde_yaml Vendorserde Affected 0.6.0 to 0.8.3 [fixed: 0.8.4 and later] Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:serde-yaml_project:serde-yaml:*:*:*:*:*:*:*:* | 0.6.0 – 0.8.3 | Vulnerable | Serde-yaml Project |
- cpe:2.3:a:serde-yaml_project:serde-yaml:*:*:*:*:*:*:*:* Versions 0.6.0 – 0.8.3 Vulnerable ·Serde-yaml Project
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2019-1010183
- 2026-10-03 Alias added: GHSA-6p2w-7q97-f8hf
References
Sources
- CVE-2019-1010183 · CVE Program
- CVE-2019-1010183 · NVD
- FIRST EPSS
- GHSA-6p2w-7q97-f8hf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences