Read the docs

SQL injection in I-doit

Priority MEDIUM 45CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-89.

Summary

Synetics GmbH I-doit 1.12 and earlier is affected by: SQL Injection. The impact is: Unauthenticated mysql database access. The component is: Web login form. The attack vector is: An attacker can exploit the vulnerability by sending a malicious HTTP POST request. The fixed version is: 1.12.1.

Why it matters now

EPSS 0.01421 73rd percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
I-DoitI-doit1.12 and earlier [fixed: 1.12.1]—No fix listedCNA
  • I-doit VendorI-Doit Affected 1.12 and earlier [fixed: 1.12.1] Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:i-doit:i-doit:*:*:*:*:*:*:*:*up to 1.12VulnerableI-Doit
  • cpe:2.3:a:i-doit:i-doit:*:*:*:*:*:*:*:* Versions up to 1.12 Vulnerable ·I-Doit

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-1010248
  2. 2026-10-03 Alias added: GHSA-4xp7-wp89-c7vm

References

  • TI-2023-19258 I-doit pro 25 and below and I-doit open 25 and below employ weak password requirements… CVSS 3.1CRITICAL 9.8
  • TI-2023-19257 i-doit pro 25 and below and I-doit open 25 and below are configured with insecure default… CVSS 3.1CRITICAL 9.8
  • TI-2019-15634 i-doit CMDB 1.12 SQL Injection via objGroupID Parameter CVSS 4.0HIGH 8.8
  • TI-2019-15635 i-doit CMDB 1.12 Arbitrary File Download via file_manager Parameter CVSS 4.0HIGH 7.1
  • TI-2023-19248 i-doit Pro v25 and below was discovered to be vulnerable to path traversal. CVSS 3.1MEDIUM 6.5
  • TI-2023-24682 I-doit pro 25 and below is vulnerable to Cross Site Scripting (XSS) via index.php. CVSS 3.1MEDIUM 5.4
See all 18 →

Sources