Read the docs
TI-2019-16099 Aliases GHSA-5f7m-mmpc-qhh4

mysql Node.JS Module Vulnerable to Remote Memory Exposure

Priority LOW 38CWE-201Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Information disclosure
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-201.

Summary

Versions of `mysql` before 2.14.0 are vulnerable to remove memory exposure. Affected versions of `mysql` package allocate and send an uninitialized memory over the network when a number is provided as a password. Only `mysql` running on Node.js versions below 6.0.0 are affected due to a throw added in newer node.js versions. Proof of Concept: ``` require('mysql').createConnection({ host: 'localhost', user: 'user', password : USERPROVIDEDINPUT, // number database : 'my_db' }).connect(); ``` ## Recommendation Update to version 2.14.0 or later.

Why it matters now

Fix Fixed mysql (npm): 2.14.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—mysql (npm)2.0.0-alpha8 to before 2.14.02.14.0Patch availableGHSA-5f7m-mmpc-qhh4
  • mysql (npm) Vendor— Affected 2.0.0-alpha8 to before 2.14.0 Fixed in 2.14.0 Patch available GHSA-5f7m-mmpc-qhh4

Remediation

  • Fix · GHSA-5f7m-mmpc-qhh4 mysql (npm) Fixed in 2.14.0 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-5f7m-mmpc-qhh4

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences