Memory Exposure in concat-stream
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-200.
Summary
Versions of `concat-stream` before 1.5.2 are vulnerable to memory exposure if userp provided input is passed into `write()` Versions <1.3.0 are not affected due to not using unguarded Buffer constructor. ## Recommendation Update to version 1.5.2, 1.4.11, 1.3.2 or later. If you are unable to update make sure user provided input into the `write()` function is not a number.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | concat-stream (npm) | 1.5.0 to before 1.5.2 | 1.5.2 | Patch available | GHSA-g74r-ffvr-5q9f |
| — | concat-stream (npm) | 1.4.0 to before 1.4.11 | 1.4.11 | Patch available | GHSA-g74r-ffvr-5q9f |
| — | concat-stream (npm) | 1.3.0 to before 1.3.2 | 1.3.2 | Patch available | GHSA-g74r-ffvr-5q9f |
- concat-stream (npm) Vendor— Affected 1.5.0 to before 1.5.2 Fixed in 1.5.2 Patch available GHSA-g74r-ffvr-5q9f
- concat-stream (npm) Vendor— Affected 1.4.0 to before 1.4.11 Fixed in 1.4.11 Patch available GHSA-g74r-ffvr-5q9f
- concat-stream (npm) Vendor— Affected 1.3.0 to before 1.3.2 Fixed in 1.3.2 Patch available GHSA-g74r-ffvr-5q9f
Remediation
- Fix · GHSA-g74r-ffvr-5q9f concat-stream (npm) Fixed in 1.5.2 Advisory →
- Fix · GHSA-g74r-ffvr-5q9f concat-stream (npm) Fixed in 1.4.11 Advisory →
- Fix · GHSA-g74r-ffvr-5q9f concat-stream (npm) Fixed in 1.3.2 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-g74r-ffvr-5q9f
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences