Read the docs
TI-2019-16117 Aliases GHSA-f7r3-p866-q9qr

ircdkit vulnerable to Denial of Service due to unhandled connection end event

Priority LOW 38CWE-400Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Denial of service
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-400.

Summary

Versions of `ircdkit` 1.0.3 and prior are vulnerable to a remote denial of service. ## Recommendation Upgrade to version 1.0.4.

Why it matters now

Fix Fixed ircdkit (npm): 1.0.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—ircdkit (npm)before 1.0.41.0.4Patch availableGHSA-f7r3-p866-q9qr
  • ircdkit (npm) Vendor— Affected before 1.0.4 Fixed in 1.0.4 Patch available GHSA-f7r3-p866-q9qr

Remediation

  • Fix · GHSA-f7r3-p866-q9qr ircdkit (npm) Fixed in 1.0.4 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-f7r3-p866-q9qr

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences