Insecure Default Configuration in redbird
Priority LOW 38CWE-20Published · Updated
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- No fix listed
No CVSS vector from any source. Fix status from GitHub.
Summary
Versions of `redbird` prior to 0.9.1 have a vulnerable default configuration of allowing TLS 1.0 connections on `lib/proxy.js`. The package does not provide an option to disable TLS 1.0 which is deprecated and vulnerable. ## Recommendation Upgrade to version 0.9.1 or later.
Why it matters now
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | redbird (npm) | up to 0.9.0 | — | No fix listed | GHSA-8948-ffc6-jg52 |
- redbird (npm) Vendor— Affected up to 0.9.0 Fixed in — No fix listed GHSA-8948-ffc6-jg52
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-03 Threatist record created from GHSA-8948-ffc6-jg52
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences