Read the docs
TI-2019-16183 Aliases GHSA-mgv2-57vj-99xc

Low severity vulnerability that affects eye.js

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

## Test breaking ### Impact In v1.2.0, tests are broken: all tests are always succeeding. If tests are looking for security vulnerabilities, these were compromised. ### Patches Users should upgrade to `v1.2.1` ### Workarounds Users who don't use eye.js for looking for vulnerabilities are safe. Upgrading will just fix some bugs. ### For more information If you have any questions or comments about this advisory: * Open an issue in [EyeJS](https://github.com/arguiot/EyeJS) * Email us at [[email protected]](mailto:[email protected])

Why it matters now

Fix Fixed eye.js (npm): 1.2.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—eye.js (npm)1.2.0 to before 1.2.11.2.1Patch availableGHSA-mgv2-57vj-99xc
  • eye.js (npm) Vendor— Affected 1.2.0 to before 1.2.1 Fixed in 1.2.1 Patch available GHSA-mgv2-57vj-99xc

Remediation

  • Fix · GHSA-mgv2-57vj-99xc eye.js (npm) Fixed in 1.2.1 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-mgv2-57vj-99xc

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences