High severity vulnerability that affects indico
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Code execution
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-77.
Summary
## Local file disclosure through LaTeX injection ### Impact An external audit of the Indico codebase has discovered a vulnerability in Indico's LaTeX sanitization code, which could have malicious users to run unsafe LaTeX commands on the server. Such commands allowed for example to read local files (e.g. `indico.conf`). As far as we know it is not possible to write files or execute code using this vulnerability. ### Patches You need to update to [Indico 2.2.3](https://github.com/indico/indico/releases/tag/v2.2.3) as soon as possible. We also released [Indico 2.1.10](https://github.com/indico/indico/releases/tag/v2.1.10) in case you cannot update to 2.2 for some reason. See https://docs.getindico.io/en/stable/installation/upgrade/ for instructions on how to update. ### Workarounds Setting `XELATEX_PATH = None` in `indico.conf` will result in an error when building a PDF, but without being able to run xelatex, the vulnerability cannot be abused. ### For more information If you have any questions or comments about this advisory: * Open a thread in [our forum](https://talk.getindico.io/) * Email us privately at [[email protected]](mailto:[email protected])
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | indico (PyPI) | before 2.1.10 | 2.1.10 | Patch available | GHSA-67cx-rhhq-mfhq |
| — | indico (PyPI) | 2.2.0 to before 2.2.3 | 2.2.3 | Patch available | GHSA-67cx-rhhq-mfhq |
- indico (PyPI) Vendor— Affected before 2.1.10 Fixed in 2.1.10 Patch available GHSA-67cx-rhhq-mfhq
- indico (PyPI) Vendor— Affected 2.2.0 to before 2.2.3 Fixed in 2.2.3 Patch available GHSA-67cx-rhhq-mfhq
Remediation
- Fix · GHSA-67cx-rhhq-mfhq indico (PyPI) Fixed in 2.1.10 Advisory →
- Fix · GHSA-67cx-rhhq-mfhq indico (PyPI) Fixed in 2.2.3 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-67cx-rhhq-mfhq
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences