Read the docs
TI-2019-16187 Aliases GHSA-4j6x-w426-6rc6

Default Express middleware security check is ignored in production

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

## Default Express middleware security check is ignored in production ### Impact All Cube.js deployments that use affected versions of `@cubejs-backend/api-gateway` with default express authentication middleware in production environment are affected. ### Patches @cubejs-backend/[email protected] ### Workarounds Override default authentication express middleware: https://cube.dev/docs/@cubejs-backend-server-core#options-reference-check-auth-middleware ### For more information If you have any questions or comments about this advisory: * Open an issue in https://github.com/cube-js/cube.js/issues * Reach out us in community Slack: https://slack.cube.dev/

Why it matters now

Fix Fixed @cubejs-backend/api-gateway (npm): 0.11.17

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—@cubejs-backend/api-gateway (npm)0.11.0 to before 0.11.170.11.17Patch availableGHSA-4j6x-w426-6rc6
  • @cubejs-backend/api-gateway (npm) Vendor— Affected 0.11.0 to before 0.11.17 Fixed in 0.11.17 Patch available GHSA-4j6x-w426-6rc6

Remediation

  • Fix · GHSA-4j6x-w426-6rc6 @cubejs-backend/api-gateway (npm) Fixed in 0.11.17 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-4j6x-w426-6rc6

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences