PAN-OS: DOM-Based cross site scripting vulnerability in management web interface
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
A DOM-Based Cross Site Scripting Vulnerability exists in PAN-OS and Panorama Management Web Interfaces. A remote attacker able to convince an authenticated administrator to click on a crafted link to PAN-OS and Panorama Web Interfaces could execute arbitrary JavaScript code in the administrator's browser and perform administrative actions. This issue affects: PAN-OS 7.1 versions earlier than 7.1.26; PAN-OS 8.1 versions earlier than 8.1.13; PAN-OS 9.0 versions earlier than 9.0.6; All versions of PAN-OS 8.0.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Palo Alto Networks | PAN-OS | all versions; 7.1 to before 7.1.26; 8.1 to before 8.1.13; 9.0 to before 9.0.6 | 7.1.26, 8.1.13, 9.0.6, 9.1.0 | Patch available | CNA |
- PAN-OS VendorPalo Alto Networks Affected all versions; 7.1 to before 7.1.26; 8.1 to before 8.1.13; 9.0 to before 9.0.6 Fixed in 7.1.26, 8.1.13, 9.0.6, 9.1.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:paloaltonetworks:pan-os:*:*:*:*:*:*:*:* | 7.1.0 to before 7.1.26; 8.0.0 – 8.0.20; 8.1.0 to before 8.1.13; 9.0.0 to before 9.0.6 | Vulnerable | CyberArk Software, a Palo Alto Networks Company |
- cpe:2.3:o:paloaltonetworks:pan-os:*:*:*:*:*:*:*:* Versions 7.1.0 to before 7.1.26; 8.0.0 – 8.0.20; 8.1.0 to before 8.1.13; 9.0.0 to before 9.0.6 Vulnerable ·CyberArk Software, a Palo Alto Networks Company
Remediation
- Fix · CNA PAN-OS (Palo Alto Networks) Fixed in 7.1.26, 8.1.13, 9.0.6, 9.1.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Palo Alto Networks PAN-OS 7.1.26, 8.1.13 and 2 more versions
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2020-01932 PAN-OS: Temporary file race condition vulnerability in PAN-OS leads to local privilege escalationPriority LOW 32
Timeline
- 2026-10-02 Threatist record created from CVE-2020-2017
- 2026-10-03 Alias added: GHSA-rh92-6783-v73r
References
More Palo Alto Networks vulnerabilities
- TI-2024-08782 Expedition: Unauthenticated OS Command Injection Vulnerability Leads to Firewall Credential Disclosure KEVCVSS 4.0CRITICAL 9.9
- TI-2024-03172 PAN-OS: Arbitrary File Creation Leads to OS Command Injection Vulnerability in GlobalProtect KEVCVSS 3.1CRITICAL 10.0
- TI-2020-01936 PAN-OS: Authentication Bypass in SAML Authentication KEVCVSS 3.1CRITICAL 10.0
- TI-2017-11675 Palo Alto Networks PAN-OS before 6.1.19, 7.0.x before 7.0.19, 7.1.x before 7.1.14, and… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-00239 PAN-OS: Unauthenticated user initiated Buffer Overflow Vulnerability in User-ID™ Authentication Portal KEVCVSS 4.0CRITICAL 9.3
- TI-2024-08784 Expedition: SQL Injection Leads to Firewall Admin Credential Disclosure KEVCVSS 4.0CRITICAL 9.2
Sources
- CVE-2020-2017 · CVE Program
- CVE-2020-2017 · NVD
- FIRST EPSS
- GHSA-rh92-6783-v73r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences