PAN-OS: Buffer overflow when Captive Portal or Multi-Factor Authentication (MFA) is enabled
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-120 and the CVSS impact.
Summary
A buffer overflow vulnerability in PAN-OS allows an unauthenticated attacker to disrupt system processes and potentially execute arbitrary code with root privileges by sending a malicious request to the Captive Portal or Multi-Factor Authentication interface. This issue impacts: All versions of PAN-OS 8.0; PAN-OS 8.1 versions earlier than PAN-OS 8.1.15; PAN-OS 9.0 versions earlier than PAN-OS 9.0.9; PAN-OS 9.1 versions earlier than PAN-OS 9.1.3.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Palo Alto Networks | PAN-OS | all versions; 9.0 to before 9.0.9; 9.1 to before 9.1.3; 8.1 to before 8.1.15 | 9.0.9, 9.1.3, 8.1.15, 10.0.0 | Patch available | CNA |
- PAN-OS VendorPalo Alto Networks Affected all versions; 9.0 to before 9.0.9; 9.1 to before 9.1.3; 8.1 to before 8.1.15 Fixed in 9.0.9, 9.1.3, 8.1.15, 10.0.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:paloaltonetworks:pan-os:*:*:*:*:*:*:*:* | 8.0.0 – 8.0.20; 8.1.0 to before 8.1.15; 9.0.0 to before 9.0.9; 9.1.0 to before 9.1.3 | Vulnerable | CyberArk Software, a Palo Alto Networks Company |
- cpe:2.3:o:paloaltonetworks:pan-os:*:*:*:*:*:*:*:* Versions 8.0.0 – 8.0.20; 8.1.0 to before 8.1.15; 9.0.0 to before 9.0.9; 9.1.0 to before 9.1.3 Vulnerable ·CyberArk Software, a Palo Alto Networks Company
Remediation
- Fix · CNA PAN-OS (Palo Alto Networks) Fixed in 9.0.9, 9.1.3, 8.1.15, 10.0.0
Timeline
- 2026-10-02 Threatist record created from CVE-2020-2040
- 2026-10-03 Alias added: GHSA-pf79-9hv7-chg5
References
More Palo Alto Networks vulnerabilities
- TI-2024-08782 Expedition: Unauthenticated OS Command Injection Vulnerability Leads to Firewall Credential Disclosure KEVCVSS 4.0CRITICAL 9.9
- TI-2024-03172 PAN-OS: Arbitrary File Creation Leads to OS Command Injection Vulnerability in GlobalProtect KEVCVSS 3.1CRITICAL 10.0
- TI-2020-01936 PAN-OS: Authentication Bypass in SAML Authentication KEVCVSS 3.1CRITICAL 10.0
- TI-2017-11675 Palo Alto Networks PAN-OS before 6.1.19, 7.0.x before 7.0.19, 7.1.x before 7.1.14, and… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-00239 PAN-OS: Unauthenticated user initiated Buffer Overflow Vulnerability in User-ID™ Authentication Portal KEVCVSS 4.0CRITICAL 9.3
- TI-2024-08784 Expedition: SQL Injection Leads to Firewall Admin Credential Disclosure KEVCVSS 4.0CRITICAL 9.2
Sources
- CVE-2020-2040 · CVE Program
- CVE-2020-2040 · NVD
- FIRST EPSS
- GHSA-pf79-9hv7-chg5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences