Jenkins NUnit Plugin 0.25 and earlier does not configure the XML parser to prevent XML external entity (XXE) attacks.
Priority MEDIUM 40CWE-611Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Jenkins NUnit Plugin 0.25 and earlier does not configure the XML parser to prevent XML external entity (XXE) attacks.
Why it matters now
EPSS 0.0115 67th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:nunit (Maven): 0.26
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins NUnit Plugin | up to 0.25 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:nunit (Maven) | before 0.26 | 0.26 | Patch available | GHSA-xvhf-q744-5xm8 |
- Jenkins NUnit Plugin VendorJenkins Affected up to 0.25 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:nunit (Maven) Vendor— Affected before 0.26 Fixed in 0.26 Patch available GHSA-xvhf-q744-5xm8
Remediation
- Fix · GHSA-xvhf-q744-5xm8 org.jenkins-ci.plugins:nunit (Maven) Fixed in 0.26 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2020-2115
- 2026-10-03 Alias added: GHSA-xvhf-q744-5xm8
References
Advisory 3
More Jenkins Nunit vulnerabilities
- TI-2022-21209 Protection mechanism failure in Jenkins NUnit Plugin CVSS 3.1MEDIUM 5.3
Sources
- CVE-2020-2115 · CVE Program
- CVE-2020-2115 · NVD
- FIRST EPSS
- GHSA-xvhf-q744-5xm8 · GitHub Advisory Database · CC BY 4.0
- CVE-2020-2115 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences