Cross-site scripting in Jenkins Brakeman Plugin
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins Brakeman Plugin 0.12 and earlier did not escape values received from parsed JSON files when rendering them, resulting in a stored cross-site scripting vulnerability exploitable by users able to control the Brakeman post-build step input data.
Why it matters now
EPSS 0.00822 57th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:brakeman (Maven): 0.13
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Brakeman Plugin | up to 0.12 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:brakeman (Maven) | before 0.13 | 0.13 | Patch available | GHSA-7q9r-vhg2-789w |
- Jenkins Brakeman Plugin VendorJenkins Affected up to 0.12 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:brakeman (Maven) Vendor— Affected before 0.13 Fixed in 0.13 Patch available GHSA-7q9r-vhg2-789w
Remediation
- Fix · GHSA-7q9r-vhg2-789w org.jenkins-ci.plugins:brakeman (Maven) Fixed in 0.13 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-2122
- 2026-10-03 Alias added: GHSA-7q9r-vhg2-789w
References
Sources
- CVE-2020-2122 · CVE Program
- CVE-2020-2122 · NVD
- FIRST EPSS
- GHSA-7q9r-vhg2-789w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences