Cross-site scripting in Jenkins Gatling Plugin
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins Gatling Plugin 1.2.7 and earlier prevents Content-Security-Policy headers from being set for Gatling reports served by the plugin, resulting in an XSS vulnerability exploitable by users able to change report content.
Why it matters now
EPSS 0.00705 53rd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:gatling (Maven): 1.3.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Gatling Plugin | up to 1.2.7; 1.2.2 and later | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:gatling (Maven) | before 1.3.0 | 1.3.0 | Patch available | GHSA-hv53-qjg6-5pm9 |
- Jenkins Gatling Plugin VendorJenkins Affected up to 1.2.7; 1.2.2 and later Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:gatling (Maven) Vendor— Affected before 1.3.0 Fixed in 1.3.0 Patch available GHSA-hv53-qjg6-5pm9
Remediation
- Fix · GHSA-hv53-qjg6-5pm9 org.jenkins-ci.plugins:gatling (Maven) Fixed in 1.3.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-2173
- 2026-10-03 Alias added: GHSA-hv53-qjg6-5pm9
References
More Jenkins Gatling vulnerabilities
- TI-2025-05236 Cross-site scripting in Jenkins Gatling Plugin CVSS 3.1HIGH 8.0
Sources
- CVE-2020-2173 · CVE Program
- CVE-2020-2173 · NVD
- FIRST EPSS
- GHSA-hv53-qjg6-5pm9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences