Cross-site scripting in Jenkins AWSEB Deployment Plugin
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins AWSEB Deployment Plugin 0.3.19 and earlier does not escape various values printed as part of form validation output, resulting in a reflected cross-site scripting vulnerability.
Why it matters now
EPSS 0.00816 57th percentileScored 2026-11-07
Fix Fixed br.com.ingenieux.jenkins.plugins:awseb-deployment-plugin (Maven): 0.3.20
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins AWSEB Deployment Plugin | up to 0.3.19 | — | No fix listed | CNA |
| — | br.com.ingenieux.jenkins.plugins:awseb-deployment-plugin (Maven) | before 0.3.20 | 0.3.20 | Patch available | GHSA-f82v-pg74-6686 |
- Jenkins AWSEB Deployment Plugin VendorJenkins Affected up to 0.3.19 Fixed in — No fix listed CNA
- br.com.ingenieux.jenkins.plugins:awseb-deployment-plugin (Maven) Vendor— Affected before 0.3.20 Fixed in 0.3.20 Patch available GHSA-f82v-pg74-6686
Remediation
- Fix · GHSA-f82v-pg74-6686 br.com.ingenieux.jenkins.plugins:awseb-deployment-plugin (Maven) Fixed in 0.3.20 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-2174
- 2026-10-03 Alias added: GHSA-f82v-pg74-6686
References
Sources
- CVE-2020-2174 · CVE Program
- CVE-2020-2174 · NVD
- FIRST EPSS
- GHSA-f82v-pg74-6686 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences