Cross-site scripting in Jenkins FitNesse Plugin
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins FitNesse Plugin 1.31 and earlier does not correctly escape report contents before showing them on the Jenkins UI, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by users able to control the XML input files processed by the plugin.
Why it matters now
EPSS 0.00705 53rd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:fitnesse (Maven): 1.32
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins FitNesse Plugin | up to 1.31 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:fitnesse (Maven) | before 1.32 | 1.32 | Patch available | GHSA-f6vx-3fq6-hxm8 |
- Jenkins FitNesse Plugin VendorJenkins Affected up to 1.31 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:fitnesse (Maven) Vendor— Affected before 1.32 Fixed in 1.32 Patch available GHSA-f6vx-3fq6-hxm8
Remediation
- Fix · GHSA-f6vx-3fq6-hxm8 org.jenkins-ci.plugins:fitnesse (Maven) Fixed in 1.32 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-2175
- 2026-10-03 Alias added: GHSA-f6vx-3fq6-hxm8
References
Advisory 2
Other 5
- [oss-security] 20200407 Multiple vulnerabilities in Jenkins plugins
- https://github.com/jenkinsci/fitnesse-plugin/commit/309d40212338ad6e388f61892e4386f6645438a9
- https://github.com/jenkinsci/fitnesse-plugin/commit/a49167115cc0a3dfca1c139c2c277a7c5c06074d
- https://github.com/jenkinsci/fitnesse-plugin/commit/db72cc49b5cb8a33359805a86a841851673def2d
- https://github.com/jenkinsci/fitnesse-plugin
More Jenkins Fitnesse vulnerabilities
- TI-2020-01997 Jenkins FitNesse Plugin 1.30 and earlier does not configure the XML parser to prevent XML external entity (XXE) attacks. CVSS 3.1HIGH 8.8
- TI-2026-41239 Jenkins FitNesse Plugin 1.36 and earlier stores passwords unencrypted in job config.xml… CVSS 3.1MEDIUM 4.3
Sources
- CVE-2020-2175 · CVE Program
- CVE-2020-2175 · NVD
- FIRST EPSS
- GHSA-f6vx-3fq6-hxm8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences