Deserialization of untrusted data in Jenkins Yaml Axis Plugin
Priority MEDIUM 43CWE-502Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
Jenkins Yaml Axis Plugin 0.2.0 and earlier does not configure its YAML parser to prevent the instantiation of arbitrary types, resulting in a remote code execution vulnerability.
Why it matters now
EPSS 0.02867 86th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:yaml-axis (Maven): 0.2.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Yaml Axis Plugin | up to 0.2.0 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:yaml-axis (Maven) | before 0.2.1 | 0.2.1 | Patch available | GHSA-324h-2v7h-q3xx |
- Jenkins Yaml Axis Plugin VendorJenkins Affected up to 0.2.0 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:yaml-axis (Maven) Vendor— Affected before 0.2.1 Fixed in 0.2.1 Patch available GHSA-324h-2v7h-q3xx
Remediation
- Fix · GHSA-324h-2v7h-q3xx org.jenkins-ci.plugins:yaml-axis (Maven) Fixed in 0.2.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-2179
- 2026-10-03 Alias added: GHSA-324h-2v7h-q3xx
References
Advisory 3
Sources
- CVE-2020-2179 · CVE Program
- CVE-2020-2179 · NVD
- FIRST EPSS
- GHSA-324h-2v7h-q3xx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences