Deserialization of untrusted data in Jenkins AWS SAM Plugin
Priority MEDIUM 42CWE-502Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
Jenkins AWS SAM Plugin 1.2.2 and earlier does not configure its YAML parser to prevent the instantiation of arbitrary types, resulting in a remote code execution vulnerability.
Why it matters now
EPSS 0.02282 83rd percentileScored 2026-11-07
Fix Fixed io.jenkins.plugins:aws-sam (Maven): 1.2.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins AWS SAM Plugin | up to 1.2.2 | — | No fix listed | CNA |
| — | io.jenkins.plugins:aws-sam (Maven) | before 1.2.3 | 1.2.3 | Patch available | GHSA-qrm8-cw73-r9w8 |
- Jenkins AWS SAM Plugin VendorJenkins Affected up to 1.2.2 Fixed in — No fix listed CNA
- io.jenkins.plugins:aws-sam (Maven) Vendor— Affected before 1.2.3 Fixed in 1.2.3 Patch available GHSA-qrm8-cw73-r9w8
Remediation
- Fix · GHSA-qrm8-cw73-r9w8 io.jenkins.plugins:aws-sam (Maven) Fixed in 1.2.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-2180
- 2026-10-03 Alias added: GHSA-qrm8-cw73-r9w8
References
Advisory 3
Sources
- CVE-2020-2180 · CVE Program
- CVE-2020-2180 · NVD
- FIRST EPSS
- GHSA-qrm8-cw73-r9w8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences