Jenkins Amazon EC2 Plugin 1.50.1 and earlier does not validate SSH host keys when…
Priority LOW 26CWE-300Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Jenkins Amazon EC2 Plugin 1.50.1 and earlier does not validate SSH host keys when connecting agents, enabling man-in-the-middle attacks.
Why it matters now
EPSS 0.00694 53rd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:ec2 (Maven): 1.50.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Amazon EC2 Plugin | up to 1.50.1 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:ec2 (Maven) | before 1.50.2 | 1.50.2 | Patch available | GHSA-q8qq-2p5p-rg44 |
- Jenkins Amazon EC2 Plugin VendorJenkins Affected up to 1.50.1 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:ec2 (Maven) Vendor— Affected before 1.50.2 Fixed in 1.50.2 Patch available GHSA-q8qq-2p5p-rg44
Remediation
- Fix · GHSA-q8qq-2p5p-rg44 org.jenkins-ci.plugins:ec2 (Maven) Fixed in 1.50.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-2185
- 2026-10-03 Alias added: GHSA-q8qq-2p5p-rg44
References
Advisory 3
More Jenkins Amazon Ec2 vulnerabilities
- TI-2020-01967 Cross-site request forgery in Jenkins Amazon EC2 Plugin CVSS 3.1HIGH 8.8
- TI-2020-01968 Missing authorization in Jenkins Amazon EC2 Plugin CVSS 3.1HIGH 8.1
- TI-2020-02064 Improper certificate validation in Jenkins Amazon EC2 Plugin CVSS 3.1MEDIUM 5.6
- TI-2020-02065 Incorrect authorization in Jenkins Amazon EC2 Plugin CVSS 3.1MEDIUM 4.3
- TI-2020-02063 Cross-site request forgery in Jenkins Amazon EC2 Plugin CVSS 3.1MEDIUM 4.3
Sources
- CVE-2020-2185 · CVE Program
- CVE-2020-2185 · NVD
- FIRST EPSS
- GHSA-q8qq-2p5p-rg44 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences