Cross-site scripting in Jenkins ECharts API Plugin
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins ECharts API Plugin 4.7.0-3 and earlier does not escape the parser identifier when rendering charts, resulting in a stored cross-site scripting vulnerability.
Why it matters now
EPSS 0.00735 54th percentileScored 2026-11-07
Fix Fixed io.jenkins.plugins:echarts-api (Maven): 4.7.0-4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins ECharts API Plugin | up to 4.7.0-3 | — | No fix listed | CNA |
| — | io.jenkins.plugins:echarts-api (Maven) | before 4.7.0-4 | 4.7.0-4 | Patch available | GHSA-x9rq-9h44-f84v |
- Jenkins ECharts API Plugin VendorJenkins Affected up to 4.7.0-3 Fixed in — No fix listed CNA
- io.jenkins.plugins:echarts-api (Maven) Vendor— Affected before 4.7.0-4 Fixed in 4.7.0-4 Patch available GHSA-x9rq-9h44-f84v
Remediation
- Fix · GHSA-x9rq-9h44-f84v io.jenkins.plugins:echarts-api (Maven) Fixed in 4.7.0-4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-2193
- 2026-10-03 Alias added: GHSA-x9rq-9h44-f84v
References
More Jenkins Echarts Api vulnerabilities
- TI-2020-02071 Cross-site scripting in Jenkins ECharts API Plugin CVSS 3.1MEDIUM 5.4
Sources
- CVE-2020-2193 · CVE Program
- CVE-2020-2193 · NVD
- FIRST EPSS
- GHSA-x9rq-9h44-f84v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences