Cross-site scripting in Jenkins Compact Columns Plugin
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins Compact Columns Plugin 1.11 and earlier displays the unprocessed job description in tooltips, resulting in a stored cross-site scripting vulnerability that can be exploited by users with Job/Configure permission.
Why it matters now
EPSS 0.00735 54th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:compact-columns (Maven): 1.12
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Compact Columns Plugin | up to 1.11 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:compact-columns (Maven) | before 1.12 | 1.12 | Patch available | GHSA-x68x-wvm2-hqc8 |
- Jenkins Compact Columns Plugin VendorJenkins Affected up to 1.11 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:compact-columns (Maven) Vendor— Affected before 1.12 Fixed in 1.12 Patch available GHSA-x68x-wvm2-hqc8
Remediation
- Fix · GHSA-x68x-wvm2-hqc8 org.jenkins-ci.plugins:compact-columns (Maven) Fixed in 1.12 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-2195
- 2026-10-03 Alias added: GHSA-x68x-wvm2-hqc8
References
Advisory 3
Sources
- CVE-2020-2195 · CVE Program
- CVE-2020-2195 · NVD
- FIRST EPSS
- GHSA-x68x-wvm2-hqc8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences