Read the docs
TI-2020-02082 Aliases CVE-2020-2205GHSA-vqp8-h53h-3jfh

Cross-site scripting in Jenkins VncRecorder Plugin

Priority LOW 23CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Jenkins VncRecorder Plugin 1.25 and earlier does not escape a tool path in the `checkVncServ` form validation endpoint, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by Jenkins administrators.

Why it matters now

EPSS 0.00702 53rd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:vncrecorder (Maven): 1.35

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins VncRecorder Pluginup to 1.25—No fix listedCNA
—org.jenkins-ci.plugins:vncrecorder (Maven)before 1.351.35Patch availableGHSA-vqp8-h53h-3jfh
  • Jenkins VncRecorder Plugin VendorJenkins Affected up to 1.25 Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:vncrecorder (Maven) Vendor— Affected before 1.35 Fixed in 1.35 Patch available GHSA-vqp8-h53h-3jfh

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:vncrecorder:*:*:*:*:*:jenkins:*:*up to 1.25VulnerableJenkins
  • cpe:2.3:a:jenkins:vncrecorder:*:*:*:*:*:jenkins:*:* Versions up to 1.25 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-vqp8-h53h-3jfh org.jenkins-ci.plugins:vncrecorder (Maven) Fixed in 1.35 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-2205
  2. 2026-10-03 Alias added: GHSA-vqp8-h53h-3jfh

References

  • TI-2020-02083 Cross-site scripting in Jenkins VncRecorder Plugin CVSS 3.1MEDIUM 6.1

Sources