Cross-site scripting in Jenkins VncViewer Plugin
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins VncViewer Plugin 1.7 and earlier does not escape a parameter value in the checkVncServ form validation endpoint, resulting in a reflected cross-site scripting (XSS) vulnerability.
Why it matters now
EPSS 0.00871 59th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:vncviewer (Maven): 1.8
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins VncViewer Plugin | up to 1.7 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:vncviewer (Maven) | before 1.8 | 1.8 | Patch available | GHSA-2j4h-cjgh-659v |
- Jenkins VncViewer Plugin VendorJenkins Affected up to 1.7 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:vncviewer (Maven) Vendor— Affected before 1.8 Fixed in 1.8 Patch available GHSA-2j4h-cjgh-659v
Remediation
- Fix · GHSA-2j4h-cjgh-659v org.jenkins-ci.plugins:vncviewer (Maven) Fixed in 1.8 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-2207
- 2026-10-03 Alias added: GHSA-2j4h-cjgh-659v
References
Advisory 3
Sources
- CVE-2020-2207 · CVE Program
- CVE-2020-2207 · NVD
- FIRST EPSS
- GHSA-2j4h-cjgh-659v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences