Cross-site scripting in Jenkins ZAP Pipeline Plugin
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins ZAP Pipeline Plugin 1.9 and earlier programmatically disables Content-Security-Policy protection for user-generated content in workspaces, archived artifacts, etc. that Jenkins offers for download.
Why it matters now
EPSS 0.00735 54th percentileScored 2026-11-07
Fix Fixed com.vrondakis.zap:zap-pipeline (Maven): 1.10
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins ZAP Pipeline Plugin | up to 1.9 | — | No fix listed | CNA |
| — | com.vrondakis.zap:zap-pipeline (Maven) | before 1.10 | 1.10 | Patch available | GHSA-4c87-9xq5-5c35 |
- Jenkins ZAP Pipeline Plugin VendorJenkins Affected up to 1.9 Fixed in — No fix listed CNA
- com.vrondakis.zap:zap-pipeline (Maven) Vendor— Affected before 1.10 Fixed in 1.10 Patch available GHSA-4c87-9xq5-5c35
Remediation
- Fix · GHSA-4c87-9xq5-5c35 com.vrondakis.zap:zap-pipeline (Maven) Fixed in 1.10 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-2214
- 2026-10-03 Alias added: GHSA-4c87-9xq5-5c35
References
Advisory 3
Sources
- CVE-2020-2214 · CVE Program
- CVE-2020-2214 · NVD
- FIRST EPSS
- GHSA-4c87-9xq5-5c35 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences