Read the docs
TI-2020-02134 Aliases CVE-2020-2257GHSA-fvwh-wv43-8qj5

Cross-site scripting in Jenkins Validating String Parameter Plugin

Priority LOW 26CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Jenkins Validating String Parameter Plugin 2.4 and earlier does not escape various user-controlled fields, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Job/Configure permission.

Why it matters now

EPSS 0.00735 54th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:validating-string-parameter (Maven): 2.5

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Validating String Parameter Pluginup to 2.4—No fix listedCNA
—org.jenkins-ci.plugins:validating-string-parameter (Maven)before 2.52.5Patch availableGHSA-fvwh-wv43-8qj5
  • Jenkins Validating String Parameter Plugin VendorJenkins Affected up to 2.4 Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:validating-string-parameter (Maven) Vendor— Affected before 2.5 Fixed in 2.5 Patch available GHSA-fvwh-wv43-8qj5

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:validating_string_parameter:*:*:*:*:*:jenkins:*:*up to 2.4VulnerableJenkins
  • cpe:2.3:a:jenkins:validating_string_parameter:*:*:*:*:*:jenkins:*:* Versions up to 2.4 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-fvwh-wv43-8qj5 org.jenkins-ci.plugins:validating-string-parameter (Maven) Fixed in 2.5 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-2257
  2. 2026-10-03 Alias added: GHSA-fvwh-wv43-8qj5

References

Sources