Cross-site scripting in Jenkins Liquibase Runner Plugin
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins Liquibase Runner Plugin 1.4.5 and earlier does not escape changeset contents, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by users able to control changeset files evaluated by the plugin.
Why it matters now
EPSS 0.00735 54th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:liquibase-runner (Maven): 1.4.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Liquibase Runner Plugin | up to 1.4.5 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:liquibase-runner (Maven) | before 1.4.6 | 1.4.6 | Patch available | GHSA-9hg7-xmf8-jxf9 |
- Jenkins Liquibase Runner Plugin VendorJenkins Affected up to 1.4.5 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:liquibase-runner (Maven) Vendor— Affected before 1.4.6 Fixed in 1.4.6 Patch available GHSA-9hg7-xmf8-jxf9
Remediation
- Fix · GHSA-9hg7-xmf8-jxf9 org.jenkins-ci.plugins:liquibase-runner (Maven) Fixed in 1.4.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-2283
- 2026-10-03 Alias added: GHSA-9hg7-xmf8-jxf9
References
Advisory 3
More Jenkins Liquibase Runner vulnerabilities
- TI-2018-15798 An arbitrary code execution vulnerability exists in Liquibase Runner Plugin version 1.3.0… CVSS 3.0HIGH 8.8
- TI-2020-02161 XML external entity injection in Jenkins Liquibase Runner Plugin CVSS 3.1HIGH 7.1
- TI-2020-02162 Missing authorization in Jenkins Liquibase Runner Plugin CVSS 3.1MEDIUM 4.3
Sources
- CVE-2020-2283 · CVE Program
- CVE-2020-2283 · NVD
- FIRST EPSS
- GHSA-9hg7-xmf8-jxf9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences