Cross-site scripting in Jenkins Active Choices Plugin
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins Active Choices Plugin 2.4 and earlier does not escape some return values of sandboxed scripts for Reactive Reference Parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Job/Configure permission.
Why it matters now
EPSS 0.00903 59th percentileScored 2026-11-07
Fix Fixed org.biouno:uno-choice (Maven): 2.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Active Choices Plugin | up to 2.4 | — | No fix listed | CNA |
| — | org.biouno:uno-choice (Maven) | before 2.5 | 2.5 | Patch available | GHSA-rjch-j5x9-fgph |
- Jenkins Active Choices Plugin VendorJenkins Affected up to 2.4 Fixed in — No fix listed CNA
- org.biouno:uno-choice (Maven) Vendor— Affected before 2.5 Fixed in 2.5 Patch available GHSA-rjch-j5x9-fgph
Remediation
- Fix · GHSA-rjch-j5x9-fgph org.biouno:uno-choice (Maven) Fixed in 2.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-2290
- 2026-10-03 Alias added: GHSA-rjch-j5x9-fgph
References
Advisory 3
More Jenkins Active Choices vulnerabilities
- TI-2021-04779 Cross-site scripting in Jenkins Active Choices Plugin CVSS 3.1MEDIUM 5.4
- TI-2021-04696 Cross-site scripting in Jenkins Active Choices Plugin CVSS 3.1MEDIUM 4.6
- TI-2020-02166 Cross-site scripting in Jenkins Active Choices Plugin CVSS 3.1MEDIUM 5.4
- TI-2017-14605 Jenkins Active Choices plugin version 1.5.3 and earlier allowed users with Job/Configure… CVSS 3.0MEDIUM 5.4
Sources
- CVE-2020-2290 · CVE Program
- CVE-2020-2290 · NVD
- FIRST EPSS
- GHSA-rjch-j5x9-fgph · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences