Improper input validation in Apple macOS
Priority LOW 29CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
An injection issue was addressed with improved validation. This issue is fixed in macOS Catalina 10.15.4. A remote attacker may be able to cause arbitrary javascript code execution.
Why it matters now
EPSS 0.01098 65th percentileScored 2026-11-07
Fix Fixed macOS (Apple): macOS Catalina 10.15.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA macOS (Apple) Fixed in macOS Catalina 10.15.4
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apple macOS macOS Catalina 10.15.4
22 records Highest priority Priority MEDIUM 5 MEDIUM, 17 LOW
Other records, highest priority first
- TI-2020-03409 Buffer overflow in Apple iOSPriority MEDIUM 48
- TI-2020-03411 Buffer overflow in Apple iOSPriority MEDIUM 45
- TI-2020-03410 Buffer overflow in Apple iOSPriority MEDIUM 45
Timeline
- 2026-10-02 Threatist record created from CVE-2020-3884
- 2026-10-03 Alias added: GHSA-3mq5-m58g-fgj3
References
Advisory 1
More Apple Mac Os X vulnerabilities
- TI-2021-01573 Apple iOS and iPadOS: A remote attacker may be able to cause arbitrary code execution KEVCVSS 3.1CRITICAL 9.8
- TI-2021-01572 Apple iOS and iPadOS: A remote attacker may be able to cause arbitrary code execution KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05975 GNU Bash through 4.3 bash43-025 processes trailing strings after certain malformed… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05157 GNU Bash through 4.3 processes trailing strings after function definitions in the values… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-01607 sapi/cgi/cgi_main.c in PHP before 5.3.12 and 5.4.x before 5.4.2, when configured as a CGI… KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02117 Out-of-bounds write in Google Chrome KEVCVSS 3.1HIGH 8.8
Sources
- CVE-2020-3884 · CVE Program
- CVE-2020-3884 · NVD
- FIRST EPSS
- GHSA-3mq5-m58g-fgj3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences