Apple macOS: A malicious application may be able to overwrite arbitrary files
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
This issue was addressed by removing the vulnerable code. This issue is fixed in macOS Catalina 10.15.4, Security Update 2020-002 Mojave, Security Update 2020-002 High Sierra. A malicious application may be able to overwrite arbitrary files.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apple | macOS | before 10.15 | 10.15 | Patch available | CNA |
- macOS VendorApple Affected before 10.15 Fixed in 10.15 Patch available CNA
CPE configurations NVD · 16
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:* | 10.13 to before 10.13.6; 10.14 to before 10.14.6; 10.15 to before 10.15.4 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.13.6:-:*:*:*:*:*:* | 10.13.6 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.13.6:security_update_2018-002:*:*:*:*:*:* | 10.13.6 security_update_2018-002 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.13.6:security_update_2018-003:*:*:*:*:*:* | 10.13.6 security_update_2018-003 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.13.6:security_update_2019-001:*:*:*:*:*:* | 10.13.6 security_update_2019-001 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.13.6:security_update_2019-002:*:*:*:*:*:* | 10.13.6 security_update_2019-002 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.13.6:security_update_2019-003:*:*:*:*:*:* | 10.13.6 security_update_2019-003 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.13.6:security_update_2019-004:*:*:*:*:*:* | 10.13.6 security_update_2019-004 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.13.6:security_update_2019-005:*:*:*:*:*:* | 10.13.6 security_update_2019-005 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.13.6:security_update_2019-006:*:*:*:*:*:* | 10.13.6 security_update_2019-006 | Vulnerable | Apple |
- cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:* Versions 10.13 to before 10.13.6; 10.14 to before 10.14.6; 10.15 to before 10.15.4 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.13.6:-:*:*:*:*:*:* Versions 10.13.6 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.13.6:security_update_2018-002:*:*:*:*:*:* Versions 10.13.6 security_update_2018-002 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.13.6:security_update_2018-003:*:*:*:*:*:* Versions 10.13.6 security_update_2018-003 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.13.6:security_update_2019-001:*:*:*:*:*:* Versions 10.13.6 security_update_2019-001 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.13.6:security_update_2019-002:*:*:*:*:*:* Versions 10.13.6 security_update_2019-002 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.13.6:security_update_2019-003:*:*:*:*:*:* Versions 10.13.6 security_update_2019-003 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.13.6:security_update_2019-004:*:*:*:*:*:* Versions 10.13.6 security_update_2019-004 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.13.6:security_update_2019-005:*:*:*:*:*:* Versions 10.13.6 security_update_2019-005 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.13.6:security_update_2019-006:*:*:*:*:*:* Versions 10.13.6 security_update_2019-006 Vulnerable ·Apple
Show 6 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:apple:mac_os_x:10.13.6:security_update_2019-007:*:*:*:*:*:* | 10.13.6 security_update_2019-007 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.13.6:security_update_2020-001:*:*:*:*:*:* | 10.13.6 security_update_2020-001 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.14.6:-:*:*:*:*:*:* | 10.14.6 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.14.6:security_update_2019-001:*:*:*:*:*:* | 10.14.6 security_update_2019-001 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.14.6:security_update_2019-002:*:*:*:*:*:* | 10.14.6 security_update_2019-002 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.14.6:security_update_2020-001:*:*:*:*:*:* | 10.14.6 security_update_2020-001 | Vulnerable | Apple |
- cpe:2.3:o:apple:mac_os_x:10.13.6:security_update_2019-007:*:*:*:*:*:* Versions 10.13.6 security_update_2019-007 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.13.6:security_update_2020-001:*:*:*:*:*:* Versions 10.13.6 security_update_2020-001 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.14.6:-:*:*:*:*:*:* Versions 10.14.6 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.14.6:security_update_2019-001:*:*:*:*:*:* Versions 10.14.6 security_update_2019-001 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.14.6:security_update_2019-002:*:*:*:*:*:* Versions 10.14.6 security_update_2019-002 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.14.6:security_update_2020-001:*:*:*:*:*:* Versions 10.14.6 security_update_2020-001 Vulnerable ·Apple
Remediation
- Fix · CNA macOS (Apple) Fixed in 10.15
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apple macOS 10.15
3 records Highest priority Priority MEDIUM 1 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2019-06269 Apple tvOS: An application may be able to gain elevated privilegesPriority MEDIUM 45
- TI-2020-03386 Use after free in Apple macOSPriority LOW 36
Timeline
- 2026-10-02 Threatist record created from CVE-2020-3896
- 2026-10-03 Alias added: GHSA-rgrg-p9fr-gcr5
References
Advisory 1
More Apple Mac Os X vulnerabilities
- TI-2021-01573 Apple iOS and iPadOS: A remote attacker may be able to cause arbitrary code execution KEVCVSS 3.1CRITICAL 9.8
- TI-2021-01572 Apple iOS and iPadOS: A remote attacker may be able to cause arbitrary code execution KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05975 GNU Bash through 4.3 bash43-025 processes trailing strings after certain malformed… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05157 GNU Bash through 4.3 processes trailing strings after function definitions in the values… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-01607 sapi/cgi/cgi_main.c in PHP before 5.3.12 and 5.4.x before 5.4.2, when configured as a CGI… KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02117 Out-of-bounds write in Google Chrome KEVCVSS 3.1HIGH 8.8
Sources
- CVE-2020-3896 · CVE Program
- CVE-2020-3896 · NVD
- FIRST EPSS
- GHSA-rgrg-p9fr-gcr5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences