Phar unserialization vulnerability in phpMussel
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
phpMussel from versions 1.0.0 and less than 1.6.0 has an unserialization vulnerability in PHP's phar wrapper. Uploading a specially crafted file to an affected version allows arbitrary code execution (discovered, tested, and confirmed by myself), so the risk factor should be regarded as very high. Newer phpMussel versions don't use PHP's phar wrapper, and are therefore unaffected. This has been fixed in version 1.6.0.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| phpMussel | phpMussel | 1.0.0 to before 1.6.0 | 1.6.0 | Patch available | CNA |
| — | phpmussel/phpmussel (Packagist) | 1.0.0 to before 1.6.0 | 1.6.0 | Patch available | GHSA-qr95-4mq5-r3fh |
| — | maikuolan/phpmussel (Packagist) | 1.0.0 to before 1.6.0 | 1.6.0 | Patch available | GHSA-qr95-4mq5-r3fh |
- phpMussel VendorphpMussel Affected 1.0.0 to before 1.6.0 Fixed in 1.6.0 Patch available CNA
- phpmussel/phpmussel (Packagist) Vendor— Affected 1.0.0 to before 1.6.0 Fixed in 1.6.0 Patch available GHSA-qr95-4mq5-r3fh
- maikuolan/phpmussel (Packagist) Vendor— Affected 1.0.0 to before 1.6.0 Fixed in 1.6.0 Patch available GHSA-qr95-4mq5-r3fh
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:phpmussel_project:phpmussel:*:*:*:*:*:*:*:* | 1.0.0 to before 1.6.0 | Vulnerable | Phpmussel Project |
- cpe:2.3:a:phpmussel_project:phpmussel:*:*:*:*:*:*:*:* Versions 1.0.0 to before 1.6.0 Vulnerable ·Phpmussel Project
Remediation
- Fix · CNA phpMussel (phpMussel) Fixed in 1.6.0
- Fix · GHSA-qr95-4mq5-r3fh phpmussel/phpmussel (Packagist) Fixed in 1.6.0 Advisory →
- Fix · GHSA-qr95-4mq5-r3fh maikuolan/phpmussel (Packagist) Fixed in 1.6.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-4043
- 2026-10-03 Alias added: GHSA-qr95-4mq5-r3fh
References
Patch 3
Advisory 3
Sources
- CVE-2020-4043 · CVE Program
- CVE-2020-4043 · NVD
- FIRST EPSS
- GHSA-qr95-4mq5-r3fh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences