Read the docs
TI-2020-04308 Aliases CVE-2020-5252GHSA-7q25-qrjw-6fg2

Malicious package may avoid detection in python auditing

Priority LOW 23CWE-807Published · Updated

Key facts

Attack vector
Local
Privileges required
High
User interaction
Required
Attack complexity
High
Impact type
—
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

The command-line "safety" package for Python has a potential security issue. There are two Python characteristics that allow malicious code to “poison-pill” command-line Safety package detection routines by disguising, or obfuscating, other malicious or non-secure packages. This vulnerability is considered to be of low severity because the attack makes use of an existing Python condition, not the Safety tool itself. This can happen if: You are running Safety in a Python environment that you don’t trust. You are running Safety from the same Python environment where you have your dependencies installed. Dependency packages are being installed arbitrarily or without proper verification. Users can mitigate this issue by doing any of the following: Perform a static analysis by installing Docker and running the Safety Docker image: $ docker run --rm -it pyupio/safety check -r requirements.txt Run Safety against a static dependencies list, such as the requirements.txt file, in a separate, clean Python environment. Run Safety from a Continuous Integration pipeline. Use PyUp.io, which runs Safety in a controlled environment and checks Python for dependencies without any need to install them. Use PyUp's Online Requirements Checker.

Why it matters now

EPSS 0.00366 30th percentileScored 2026-11-07
Fix Fixed safety (pyupio): 1.9.0safety (PyPI): 1.9.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
pyupiosafetybefore 1.9.01.9.0Patch availableCNA
—safety (PyPI)before 1.9.01.9.0Patch availableGHSA-7q25-qrjw-6fg2
  • safety Vendorpyupio Affected before 1.9.0 Fixed in 1.9.0 Patch available CNA
  • safety (PyPI) Vendor— Affected before 1.9.0 Fixed in 1.9.0 Patch available GHSA-7q25-qrjw-6fg2

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:pyup:safety:*:*:*:*:*:*:*:*up to 1.8.6VulnerablePyup
  • cpe:2.3:a:pyup:safety:*:*:*:*:*:*:*:* Versions up to 1.8.6 Vulnerable ·Pyup

Remediation

  • Fix · CNA safety (pyupio) Fixed in 1.9.0
  • Fix · GHSA-7q25-qrjw-6fg2 safety (PyPI) Fixed in 1.9.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-5252
  2. 2026-10-03 Alias added: GHSA-7q25-qrjw-6fg2

References

Sources