Privilege escalation in setuid mode via user namespaces in Bubblewrap
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-269.
Summary
Bubblewrap (bwrap) before version 0.4.1, if installed in setuid mode and the kernel supports unprivileged user namespaces, then the `bwrap --userns2` option can be used to make the setuid process keep running as root while being traceable. This can in turn be used to gain root permissions. Note that this only affects the combination of bubblewrap in setuid mode (which is typically used when unprivileged user namespaces are not supported) and the support of unprivileged user namespaces. Known to be affected are: * Debian testing/unstable, if unprivileged user namespaces enabled (not default) * Debian buster-backports, if unprivileged user namespaces enabled (not default) * Arch if using `linux-hardened`, if unprivileged user namespaces enabled (not default) * Centos 7 flatpak COPR, if unprivileged user namespaces enabled (not default) This has been fixed in the 0.4.1 release, and all affected users should update.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| containers | bubblewrap | before 0.4.1 | 0.4.1 | Patch available | CNA |
- bubblewrap Vendorcontainers Affected before 0.4.1 Fixed in 0.4.1 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:projectatomic:bubblewrap:*:*:*:*:*:*:*:* | before 0.4.1 | Vulnerable | Project Atomic |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:archlinux:arch_linux:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | Archlinux |
| cpe:2.3:o:centos:centos:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Centos |
- cpe:2.3:a:projectatomic:bubblewrap:*:*:*:*:*:*:*:* Versions before 0.4.1 Vulnerable ·Project Atomic
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:archlinux:arch_linux:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·Archlinux
- cpe:2.3:o:centos:centos:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Centos
Remediation
- Fix · CNA bubblewrap (containers) Fixed in 0.4.1
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 3 products
- CloudForms Management Engine 5
- Red Hat Ansible Tower 3
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2020-5291
References
More containers vulnerabilities
- TI-2025-18645 .krun_config.json symlink attack creates or overwrites file on the host in crun CVSS 4.0HIGH 8.5
- TI-2026-23721 Crun incorrectly parses `crun exec` option `-u`, leading to privilege escalation CVSS 3.1HIGH 7.8
- TI-2026-37901 fuse-overlayfs release-1.x preserves SUID/SGID bits after truncate/open(O_TRUNC) CVSS 4.0LOW 2.0
- TI-2026-29788 bubblewrap vulnerable to privilege escalation in setuid mode via ptrace CVSS 4.0HIGH 8.7
- TI-2024-07805 Containers/aardvark-dns: tcp query handling flaw in aardvark-dns leading to denial of service CVSS 3.1HIGH 7.5
- TI-2024-08665 Podman: buildah: cri-o: fips crypto-policy directory mounting issue in containers/common go library CVSS 3.1HIGH 8.2
Sources
- CVE-2020-5291 · CVE Program
- CVE-2020-5291 · NVD
- FIRST EPSS
- CVE-2020-5291 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences