libImaging/FliDecode.c in Pillow before 6.2.2 has an FLI buffer overflow.
Priority LOW 36CWE-125Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · High
- Fix status
- Partial Red Hat: 9 fixed, 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
libImaging/FliDecode.c in Pillow before 6.2.2 has an FLI buffer overflow.
Why it matters now
EPSS 0.02752 86th percentileScored 2026-11-07
Fix Partial Pillow (PyPI): 6.2.2Red Hat: 3 advisoriesRed Hat: 9 fixed, 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Pillow (PyPI) | before 6.2.2 | 6.2.2 | Patch available | GHSA-hj69-c76v-86wr |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Pillow (PyPI) Vendor— Affected before 6.2.2 Fixed in 6.2.2 Patch available GHSA-hj69-c76v-86wr
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:python:pillow:*:*:*:*:*:*:*:* | before 6.2.2 | Vulnerable | python-pillow |
| cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:esm:*:*:* | 14.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:esm:*:*:* | 16.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* | 18.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:19.10:*:*:*:*:*:*:* | 19.10 | Vulnerable | Canonical |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:* | 30 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:* | 31 | Vulnerable | Fedoraproject |
- cpe:2.3:a:python:pillow:*:*:*:*:*:*:*:* Versions before 6.2.2 Vulnerable ·python-pillow
- cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:esm:*:*:* Versions 14.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:esm:*:*:* Versions 16.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:19.10:*:*:*:*:*:*:* Versions 19.10 Vulnerable ·Canonical
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:* Versions 30 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:* Versions 31 Vulnerable ·Fedoraproject
Remediation
- Fix · GHSA-hj69-c76v-86wr Pillow (PyPI) Fixed in 6.2.2 Advisory →
Red Hat 3 advisories
- RHSA-2021:0420 Released 2021-02-04 · Red Hat rating ModerateRed Hat Quay v3.4.0 security update
- Quay v3 quay/clair-rhel8, quay/quay-bridge-operator-bundle, quay/quay-bridge-operator-rhel8 +8
- RHSA-2020:3887 Released 2020-09-29 · Red Hat rating Moderatepython-pillow security update
- Red Hat Enterprise Linux Client (v. 7) python-pillow-2.0.0-21.gitd1c6db8.el7
- Red Hat Enterprise Linux Client Optional (v. 7) python-pillow-2.0.0-21.gitd1c6db8.el7, python-pillow-devel-2.0.0-21.gitd1c6db8.el7, python-pillow-doc-2.0.0-21.gitd1c6db8.el7 +3
- Red Hat Enterprise Linux ComputeNode Optional (v. 7) python-pillow-2.0.0-21.gitd1c6db8.el7, python-pillow-devel-2.0.0-21.gitd1c6db8.el7, python-pillow-doc-2.0.0-21.gitd1c6db8.el7 +3
- Red Hat Enterprise Linux Server (v. 7) python-pillow-2.0.0-21.gitd1c6db8.el7
- Red Hat Enterprise Linux Server Optional (v. 7) python-pillow-2.0.0-21.gitd1c6db8.el7, python-pillow-2.0.0-21.gitd1c6db8.el7.ppc, python-pillow-devel-2.0.0-21.gitd1c6db8.el7 +5
- Red Hat Enterprise Linux Workstation (v. 7) python-pillow-2.0.0-21.gitd1c6db8.el7
- Red Hat Enterprise Linux Workstation Optional (v. 7) python-pillow-2.0.0-21.gitd1c6db8.el7, python-pillow-devel-2.0.0-21.gitd1c6db8.el7, python-pillow-doc-2.0.0-21.gitd1c6db8.el7 +3
- RHSA-2020:3185 Released 2020-07-28 · Red Hat rating Importantpython-pillow security update
- Red Hat Enterprise Linux AppStream (v. 8) python-pillow-5.1.1-12.el8_2, python3-pillow-5.1.1-12.el8_2
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 5 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Quay v3 | Fixed | RHSA-2021:0420 |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2020:3185 |
| Red Hat Enterprise Linux Client (v. 7) | Fixed | RHSA-2020:3887 |
| Red Hat Enterprise Linux Client Optional (v. 7) | Fixed | RHSA-2020:3887 |
| Red Hat Enterprise Linux ComputeNode Optional (v. 7) | Fixed | RHSA-2020:3887 |
| Red Hat Enterprise Linux Server (v. 7) | Fixed | RHSA-2020:3887 |
| Red Hat Enterprise Linux Server Optional (v. 7) | Fixed | RHSA-2020:3887 |
| Red Hat Enterprise Linux Workstation (v. 7) | Fixed | RHSA-2020:3887 |
| Red Hat Enterprise Linux Workstation Optional (v. 7) | Fixed | RHSA-2020:3887 |
Timeline
- 2026-10-02 Threatist record created from CVE-2020-5313
- 2026-10-03 Alias added: GHSA-hj69-c76v-86wr
References
Advisory 7
Other 6
- https://github.com/pypa/advisory-database/tree/main/vulns/pillow/PYSEC-2020-84.yaml
- https://github.com/python-pillow/Pillow
- https://github.com/python-pillow/Pillow/blob/master/CHANGES.rst#622-2020-01-02
- https://lists.fedoraproject.org/archives/list/[email protected]/message/2MMU3WT2X64GS5WHDPKKC2WZA7UIIQ3A
- https://lists.fedoraproject.org/archives/list/[email protected]/message/3DUMIBUYGJRAVJCTFUWBRLVQKOUTVX5P
- https://usn.ubuntu.com/4272-1
Sources
- CVE-2020-5313 · CVE Program
- CVE-2020-5313 · NVD
- FIRST EPSS
- GHSA-hj69-c76v-86wr · GitHub Advisory Database · CC BY 4.0
- CVE-2020-5313 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences