Improper array index validation in Dell Unity
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-129 and the CVSS impact.
Summary
Dell EMC Unity, Dell EMC Unity XT, and Dell EMC UnityVSA versions prior to 5.0.2.0.5.009 contain a Denial of Service vulnerability on NAS Server SSH implementation that is used to provide SFTP service on a NAS server. A remote unauthenticated attacker may potentially exploit this vulnerability and cause a Denial of Service (Storage Processor Panic) by sending an out of order SSH protocol sequence.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell | Unity | before 5.0.2.0.5.009 | 5.0.2.0.5.009 | Patch available | CNA |
- Unity VendorDell Affected before 5.0.2.0.5.009 Fixed in 5.0.2.0.5.009 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dell:emc_unity_operating_environment:*:*:*:*:*:*:*:* | before 5.0.2.0.5.009 | Vulnerable | Dell |
| cpe:2.3:a:dell:emc_unity_xt_operating_environment:*:*:*:*:*:*:*:* | before 5.0.2.0.5.009 | Vulnerable | Dell |
| cpe:2.3:a:dell:emc_unityvsa_operating_environment:*:*:*:*:*:*:*:* | before 5.0.2.0.5.009 | Vulnerable | Dell |
- cpe:2.3:a:dell:emc_unity_operating_environment:*:*:*:*:*:*:*:* Versions before 5.0.2.0.5.009 Vulnerable ·Dell
- cpe:2.3:a:dell:emc_unity_xt_operating_environment:*:*:*:*:*:*:*:* Versions before 5.0.2.0.5.009 Vulnerable ·Dell
- cpe:2.3:a:dell:emc_unityvsa_operating_environment:*:*:*:*:*:*:*:* Versions before 5.0.2.0.5.009 Vulnerable ·Dell
Remediation
- Fix · CNA Unity (Dell) Fixed in 5.0.2.0.5.009
Timeline
- 2026-10-02 Threatist record created from CVE-2020-5319
- 2026-10-03 Alias added: GHSA-c2m8-8qv3-5rrj
References
More Dell Emc Unity Operating Environment vulnerabilities
- TI-2021-14655 OS command injection in Dell VNX2 CVSS 3.1CRITICAL 9.8
- TI-2018-01098 XML external entity injection in Dell EMC Unisphere for VMAX Virtual Appliance, Dell EMC… CVSS 3.0CRITICAL 9.8
- TI-2021-14660 Dell VNX2 OE for File versions 8.1.21.266 and earlier, contain an authentication bypass… CVSS 3.1CRITICAL 9.8
- TI-2021-14656 Path traversal in Dell VNX2 CVSS 3.1CRITICAL 9.1
- TI-2021-14662 OS command injection in Dell VNX Control Station CVSS 3.1HIGH 7.2
- TI-2021-14661 OS command injection in Dell VNX Control Station CVSS 3.1HIGH 7.2
Sources
- CVE-2020-5319 · CVE Program
- CVE-2020-5319 · NVD
- FIRST EPSS
- GHSA-c2m8-8qv3-5rrj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences