Code injection in HtmlUnit
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
HtmlUnit prior to 2.37.0 contains code execution vulnerabilities. HtmlUnit initializes Rhino engine improperly, hence a malicious JavScript code can execute arbitrary Java code on the application. Moreover, when embedded in Android application, Android-specific initialization of Rhino engine is done in an improper way, hence a malicious JavaScript code can execute arbitrary Java code on the application.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HtmlUnit Project | HtmlUnit | before 2.37.0 | 2.37.0 | Patch available | CNA |
| — | net.sourceforge.htmlunit:htmlunit (Maven) | before 2.37.0 | 2.37.0 | Patch available | GHSA-5mh9-r3rr-9597 |
- HtmlUnit VendorHtmlUnit Project Affected before 2.37.0 Fixed in 2.37.0 Patch available CNA
- net.sourceforge.htmlunit:htmlunit (Maven) Vendor— Affected before 2.37.0 Fixed in 2.37.0 Patch available GHSA-5mh9-r3rr-9597
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:htmlunit:htmlunit:*:*:*:*:*:*:*:* | before 2.37.0 | Vulnerable | HtmlUnit |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:esm:*:*:* | 16.04 | Vulnerable | Canonical |
| cpe:2.3:a:apache:camel:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | Apache |
- cpe:2.3:a:htmlunit:htmlunit:*:*:*:*:*:*:*:* Versions before 2.37.0 Vulnerable ·HtmlUnit
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:esm:*:*:* Versions 16.04 Vulnerable ·Canonical
- cpe:2.3:a:apache:camel:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·Apache
Remediation
- Fix · CNA HtmlUnit (HtmlUnit Project) Fixed in 2.37.0
- Fix · GHSA-5mh9-r3rr-9597 net.sourceforge.htmlunit:htmlunit (Maven) Fixed in 2.37.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 1 product
- Red Hat Single Sign-On 7
Timeline
- 2026-10-02 Threatist record created from CVE-2020-5529
- 2026-10-03 Alias added: GHSA-5mh9-r3rr-9597
References
Advisory 5
Other 6
- [camel-commits] 20200520 [camel] branch camel-2.25.x updated: Updating htmlunit due to CVE-2020-5529
- https://github.com/HtmlUnit/htmlunit/commit/bc1f58d483cc8854a9c4c1739abd5e04a2eb0367
- https://github.com/HtmlUnit/htmlunit
- https://jvn.jp/en/jp/JVN34535327
- https://lists.apache.org/thread.html/ra2cd7f8e61dc6b8a2d9065094cd1f46aa63ad10f237ee363e26e8563@%3Ccommits.camel.apache.org%3E
- https://usn.ubuntu.com/4584-1
Sources
- CVE-2020-5529 · CVE Program
- CVE-2020-5529 · NVD
- FIRST EPSS
- GHSA-5mh9-r3rr-9597 · GitHub Advisory Database · CC BY 4.0
- CVE-2020-5529 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences