Information disclosure in NGINX Controller
Priority LOW 25CWE-200Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-200.
Summary
In versions of NGINX Controller prior to 3.3.0, the helper.sh script, which is used optionally in NGINX Controller to change settings, uses sensitive items as command-line arguments.
Why it matters now
EPSS 0.0034 27th percentileScored 2026-11-07
Fix Fixed NGINX Controller: 3.3.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | NGINX Controller | before 3.3.0 | 3.3.0 | Patch available | CNA |
- NGINX Controller Vendor— Affected before 3.3.0 Fixed in 3.3.0 Patch available CNA
Remediation
- Fix · CNA NGINX Controller Fixed in 3.3.0
Timeline
- 2026-10-02 Threatist record created from CVE-2020-5866
- 2026-10-03 Alias added: GHSA-28pm-98wm-6937
References
More F5 Nginx Controller vulnerabilities
- TI-2020-16818 Path traversal in NGINX Controller CVSS 3.1CRITICAL 9.8
- TI-2020-04819 Cross-site scripting in NGINX Controller CVSS 3.1CRITICAL 9.6
- TI-2020-04781 In NGINX Controller versions prior to 3.2.0, an unauthenticated attacker with network… CVSS 3.1HIGH 8.6
- TI-2020-04818 Cross-site request forgery in NGINX Controller CVSS 3.1HIGH 8.8
- TI-2020-04812 Session fixation in NGINX Controller CVSS 3.1HIGH 8.1
- TI-2020-04785 Cleartext transmission of sensitive information in NGINX Controller CVSS 3.1HIGH 8.1
Sources
- CVE-2020-5866 · CVE Program
- CVE-2020-5866 · NVD
- FIRST EPSS
- GHSA-28pm-98wm-6937 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences