Cross-site scripting in SAP Automated Note Search Tool
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Under certain conditions, ABAP Online Community in SAP NetWeaver (SAP_BASIS version 7.40) and SAP S/4HANA (SAP_BASIS versions 7.50, 7.51, 7.52, 7.53, 7.54), does not sufficiently encode user-controlled inputs, resulting in Reflected Cross-Site Scripting (XSS) vulnerability.
Why it matters now
EPSS 0.00963 61st percentileScored 2026-11-07
Fix Fixed Automated Note Search Tool (SAP Basis) (SAP SE): 7.0, 7.01, 7.02 +7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SAP | Automated Note Search Tool (SAP Basis) | before 7.0; before 7.01; before 7.02; before 7.31; before 7.4; before 7.5; before 7.51; before 7.52; before 7.53; before 7.54 | 7.0, 7.01, 7.02, 7.31, 7.4, 7.5, 7.51, 7.52, 7.53, 7.54 | Patch available | CNA |
- Automated Note Search Tool (SAP Basis) VendorSAP Affected before 7.0; before 7.01; before 7.02; before 7.31; before 7.4; before 7.5; before 7.51; before 7.52; before 7.53; before 7.54 Fixed in 7.0, 7.01, 7.02, 7.31, 7.4, 7.5, 7.51, 7.52, 7.53, 7.54 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sap:netweaver:7.40:*:*:*:*:*:*:* | 7.40 | Vulnerable | SAP |
| cpe:2.3:a:sap:s\/4hana:7.50:*:*:*:*:*:*:* | 7.50 | Vulnerable | SAP |
| cpe:2.3:a:sap:s\/4hana:7.51:*:*:*:*:*:*:* | 7.51 | Vulnerable | SAP |
| cpe:2.3:a:sap:s\/4hana:7.52:*:*:*:*:*:*:* | 7.52 | Vulnerable | SAP |
| cpe:2.3:a:sap:s\/4hana:7.53:*:*:*:*:*:*:* | 7.53 | Vulnerable | SAP |
| cpe:2.3:a:sap:s\/4hana:7.54:*:*:*:*:*:*:* | 7.54 | Vulnerable | SAP |
- cpe:2.3:a:sap:netweaver:7.40:*:*:*:*:*:*:* Versions 7.40 Vulnerable ·SAP
- cpe:2.3:a:sap:s\/4hana:7.50:*:*:*:*:*:*:* Versions 7.50 Vulnerable ·SAP
- cpe:2.3:a:sap:s\/4hana:7.51:*:*:*:*:*:*:* Versions 7.51 Vulnerable ·SAP
- cpe:2.3:a:sap:s\/4hana:7.52:*:*:*:*:*:*:* Versions 7.52 Vulnerable ·SAP
- cpe:2.3:a:sap:s\/4hana:7.53:*:*:*:*:*:*:* Versions 7.53 Vulnerable ·SAP
- cpe:2.3:a:sap:s\/4hana:7.54:*:*:*:*:*:*:* Versions 7.54 Vulnerable ·SAP
Remediation
- Fix · CNA Automated Note Search Tool (SAP Basis) (SAP SE) Fixed in 7.0, 7.01, 7.02, 7.31, 7.4, 7.5, 7.51, 7.52, 7.53, 7.54
Timeline
- 2026-10-02 Threatist record created from CVE-2020-6184
- 2026-10-03 Alias added: GHSA-c743-639c-676m
References
More SAP Netweaver vulnerabilities
- TI-2025-22522 Missing Authorization check in SAP NetWeaver (Visual Composer development server) KEVCVSS 3.1CRITICAL 10.0
- TI-2021-15842 Path traversal in SAP NetWeaver KEVCVSS 3.1CRITICAL 9.9
- TI-2025-27866 Insecure Deserialization in SAP NetWeaver (Visual Composer development server) KEVCVSS 3.1CRITICAL 9.1
- TI-2012-02262 The DiagTraceR3Info function in the Dialog processor in disp+work.exe 7010.29.15.58313… CVSS 2.0HIGH 9.3
- TI-2013-01399 A Buffer Overflow vulnerability exists in the Message Server service… CVSS 3.1CRITICAL 9.8
- TI-2016-02149 Directory traversal vulnerability in the GetFileList function in the SAP Manufacturing… CVSS 3.0HIGH 7.5
Sources
- CVE-2020-6184 · CVE Program
- CVE-2020-6184 · NVD
- FIRST EPSS
- GHSA-c743-639c-676m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences