Improper input validation in SAP NetWeaver Application Server Java
Priority LOW 34CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
SAP NetWeaver Application Server Java (User Management Engine), versions- 7.10, 7.11, 7.20, 7.30, 7.31, 7.40, 7.50; does not sufficiently validate the LDAP data source configuration XML document accepted from an untrusted source, leading to Missing XML Validation.
Why it matters now
EPSS 0.01065 64th percentileScored 2026-11-07
Fix Fixed SAP NetWeaver Application Server Java (User Management Engine) (SAP SE): 7.10, 7.11, 7.20 +4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SAP | SAP NetWeaver Application Server Java (User Management Engine) | before 7.10; before 7.11; before 7.20; before 7.30; before 7.31; before 7.40; before 7.50 | 7.10, 7.11, 7.20, 7.30, 7.31, 7.40, 7.50 | Patch available | CNA |
- SAP NetWeaver Application Server Java (User Management Engine) VendorSAP Affected before 7.10; before 7.11; before 7.20; before 7.30; before 7.31; before 7.40; before 7.50 Fixed in 7.10, 7.11, 7.20, 7.30, 7.31, 7.40, 7.50 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sap:netweaver_application_server_java:7.10:*:*:*:*:*:*:* | 7.10 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_java:7.20:*:*:*:*:*:*:* | 7.20 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_java:7.30:*:*:*:*:*:*:* | 7.30 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_java:7.31:*:*:*:*:*:*:* | 7.31 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_java:7.40:*:*:*:*:*:*:* | 7.40 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_java:7.50:*:*:*:*:*:*:* | 7.50 | Vulnerable | SAP |
- cpe:2.3:a:sap:netweaver_application_server_java:7.10:*:*:*:*:*:*:* Versions 7.10 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_java:7.20:*:*:*:*:*:*:* Versions 7.20 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_java:7.30:*:*:*:*:*:*:* Versions 7.30 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_java:7.31:*:*:*:*:*:*:* Versions 7.31 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_java:7.40:*:*:*:*:*:*:* Versions 7.40 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_java:7.50:*:*:*:*:*:*:* Versions 7.50 Vulnerable ·SAP
Remediation
- Fix · CNA SAP NetWeaver Application Server Java (User Management Engine) (SAP SE) Fixed in 7.10, 7.11, 7.20, 7.30, 7.31, 7.40, 7.50
Timeline
- 2026-10-02 Threatist record created from CVE-2020-6202
- 2026-10-03 Alias added: GHSA-q8x7-f6f7-8j2h
References
More SAP Netweaver Application Server Java vulnerabilities
- TI-2020-05139 Missing authentication in SAP NetWeaver AS JAVA KEVCVSS 3.1CRITICAL 10.0
- TI-2016-02146 SQL injection vulnerability in the UDDI server in SAP NetWeaver J2EE Engine 7.40 allows… KEVCVSS 3.1CRITICAL 9.8
- TI-2010-05023 The Invoker Servlet on SAP NetWeaver Application Server Java platforms, possibly before… KEVCVSS 3.1CRITICAL 10.0
- TI-2017-09362 Directory traversal vulnerability in scheduler/ui/js/ffffffffbca41eb4/UIUtilJavaScriptJS… KEVCVSS 3.1HIGH 7.5
- TI-2016-03377 Directory traversal vulnerability in SAP NetWeaver AS Java 7.1 through 7.5 allows remote… KEVCVSS 3.1HIGH 7.5
- TI-2016-07786 BC-BMT-BPM-DSK in SAP NetWeaver AS JAVA 7.5 allows remote authenticated users to conduct… KEVCVSS 3.1MEDIUM 6.5
Sources
- CVE-2020-6202 · CVE Program
- CVE-2020-6202 · NVD
- FIRST EPSS
- GHSA-q8x7-f6f7-8j2h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences