Cross-site scripting in SAP NetWeaver Application Server Java
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
SAP NetWeaver Application Server Java, versions - 7.10, 7.11, 7.20, 7.30, 7.31, 7.40, and 7.50 allows an unauthenticated attacker to include JavaScript blocks in any web page or URL with different symbols which are otherwise not allowed. On successful exploitation an attacker can steal authentication information of the user, such as data relating to his or her current session and limitedly impact confidentiality and integrity of the application, leading to Reflected Cross Site Scripting.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SAP | SAP NetWeaver Application Server Java | before 7.10; before 7.11; before 7.20; before 7.30; before 7.31; before 7.40; before 7.50 | 7.10, 7.11, 7.20, 7.30, 7.31, 7.40, 7.50 | Patch available | CNA |
- SAP NetWeaver Application Server Java VendorSAP Affected before 7.10; before 7.11; before 7.20; before 7.30; before 7.31; before 7.40; before 7.50 Fixed in 7.10, 7.11, 7.20, 7.30, 7.31, 7.40, 7.50 Patch available CNA
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sap:netweaver_application_server_java:7.10:*:*:*:*:*:*:* | 7.10 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_java:7.11:*:*:*:*:*:*:* | 7.11 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_java:7.20:*:*:*:*:*:*:* | 7.20 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_java:7.30:*:*:*:*:*:*:* | 7.30 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_java:7.31:*:*:*:*:*:*:* | 7.31 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_java:7.40:*:*:*:*:*:*:* | 7.40 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_java:7.50:*:*:*:*:*:*:* | 7.50 | Vulnerable | SAP |
- cpe:2.3:a:sap:netweaver_application_server_java:7.10:*:*:*:*:*:*:* Versions 7.10 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_java:7.11:*:*:*:*:*:*:* Versions 7.11 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_java:7.20:*:*:*:*:*:*:* Versions 7.20 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_java:7.30:*:*:*:*:*:*:* Versions 7.30 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_java:7.31:*:*:*:*:*:*:* Versions 7.31 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_java:7.40:*:*:*:*:*:*:* Versions 7.40 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_java:7.50:*:*:*:*:*:*:* Versions 7.50 Vulnerable ·SAP
Remediation
- Fix · CNA SAP NetWeaver Application Server Java (SAP SE) Fixed in 7.10, 7.11, 7.20, 7.30, 7.31, 7.40, 7.50
Timeline
- 2026-10-02 Threatist record created from CVE-2020-6319
- 2026-10-03 Alias added: GHSA-gjm9-7g42-644v
References
More SAP Netweaver Application Server Java vulnerabilities
- TI-2020-05139 Missing authentication in SAP NetWeaver AS JAVA KEVCVSS 3.1CRITICAL 10.0
- TI-2016-02146 SQL injection vulnerability in the UDDI server in SAP NetWeaver J2EE Engine 7.40 allows… KEVCVSS 3.1CRITICAL 9.8
- TI-2010-05023 The Invoker Servlet on SAP NetWeaver Application Server Java platforms, possibly before… KEVCVSS 3.1CRITICAL 10.0
- TI-2017-09362 Directory traversal vulnerability in scheduler/ui/js/ffffffffbca41eb4/UIUtilJavaScriptJS… KEVCVSS 3.1HIGH 7.5
- TI-2016-03377 Directory traversal vulnerability in SAP NetWeaver AS Java 7.1 through 7.5 allows remote… KEVCVSS 3.1HIGH 7.5
- TI-2016-07786 BC-BMT-BPM-DSK in SAP NetWeaver AS JAVA 7.5 allows remote authenticated users to conduct… KEVCVSS 3.1MEDIUM 6.5
Sources
- CVE-2020-6319 · CVE Program
- CVE-2020-6319 · NVD
- FIRST EPSS
- GHSA-gjm9-7g42-644v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences