Cross-site scripting in Google Chrome
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Insufficient policy enforcement in iOSWeb in Google Chrome on iOS prior to 85.0.4183.83 allowed a remote attacker to bypass navigation restrictions via a crafted HTML page.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Chrome | before 85.0.4183.83 | 85.0.4183.83 | Patch available | CNA |
- Chrome VendorGoogle Affected before 85.0.4183.83 Fixed in 85.0.4183.83 Patch available CNA
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:* | before 85.0.4183.83 | Vulnerable | |
| cpe:2.3:o:apple:iphone_os:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Apple |
| cpe:2.3:a:opensuse:backports_sle:15.0:sp1:*:*:*:*:*:* | 15.0 sp1 | Vulnerable | openSUSE |
| cpe:2.3:a:opensuse:backports_sle:15.0:sp2:*:*:*:*:*:* | 15.0 sp2 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* | 15.1 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:* | 15.2 | Vulnerable | openSUSE |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:* Versions before 85.0.4183.83 Vulnerable ·Google
- cpe:2.3:o:apple:iphone_os:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Apple
- cpe:2.3:a:opensuse:backports_sle:15.0:sp1:*:*:*:*:*:* Versions 15.0 sp1 Vulnerable ·openSUSE
- cpe:2.3:a:opensuse:backports_sle:15.0:sp2:*:*:*:*:*:* Versions 15.0 sp2 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* Versions 15.1 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:* Versions 15.2 Vulnerable ·openSUSE
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA Chrome (Google) Fixed in 85.0.4183.83
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Google Chrome — openSUSE-SU-2020:1499
19 records Highest priority Priority MEDIUM 3 MEDIUM, 16 LOW
Other records, highest priority first
- TI-2020-05422 Use after free in Google ChromePriority MEDIUM 45
- TI-2020-05408 Use after free in Google ChromePriority MEDIUM 42
- TI-2020-05425 Use after free in Google ChromePriority MEDIUM 41
- Advisory ·
Google Chrome — openSUSE-SU-2020:1510
19 records Highest priority Priority MEDIUM 3 MEDIUM, 16 LOW
Other records, highest priority first
- TI-2020-05422 Use after free in Google ChromePriority MEDIUM 45
- TI-2020-05408 Use after free in Google ChromePriority MEDIUM 42
- TI-2020-05425 Use after free in Google ChromePriority MEDIUM 41
Show 1 more group
- Advisory ·
Google Chrome — openSUSE-SU-2020:1514
19 records Highest priority Priority MEDIUM 3 MEDIUM, 16 LOW
Other records, highest priority first
- TI-2020-05422 Use after free in Google ChromePriority MEDIUM 45
- TI-2020-05408 Use after free in Google ChromePriority MEDIUM 42
- TI-2020-05425 Use after free in Google ChromePriority MEDIUM 41
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 1 product
- Red Hat Enterprise Linux 6
Timeline
- 2026-10-02 Threatist record created from CVE-2020-6558
- 2026-10-03 Alias added: GHSA-wrrv-22mc-5gj3
References
More Google Chrome vulnerabilities
- TI-2025-09686 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.8
- TI-2024-07390 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04898 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04600 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04346 Use after free in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2023-05824 Integer overflow in Google Chrome KEVCVSS 3.1CRITICAL 9.6
Sources
- CVE-2020-6558 · CVE Program
- CVE-2020-6558 · NVD
- FIRST EPSS
- GHSA-wrrv-22mc-5gj3 · GitHub Advisory Database · CC BY 4.0
- CVE-2020-6558 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences