Improper privilege management in GE Digital CIMPLICITY
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-269.
Summary
A local privilege escalation vulnerability has been identified in the GE Digital CIMPLICITY HMI/SCADA product v10.0 and prior. If exploited, this vulnerability could allow an adversary to modify the system, leading to the arbitrary execution of code. This vulnerability is only exploitable if an attacker has access to an authenticated session. GE Digital CIMPLICITY v11.0, released January 2020, contains mitigation for this local privilege escalation vulnerability. GE Digital recommends all users upgrade to GE CIMPLICITY v11.0 or newer.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | GE Digital CIMPLICITY | up to v10.0 | — | No fix listed | CNA |
- GE Digital CIMPLICITY Vendor— Affected up to v10.0 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2020-6992
- 2026-10-03 Alias added: GHSA-xw2r-q7pv-2r5q
References
More GE Cimplicity vulnerabilities
- TI-2022-06170 ICSA-22-053-02 GE Proficy CIMPLICITY-Cleartext CVSS 3.1CRITICAL 9.8
- TI-2018-10924 XXE in GE Proficy Cimplicity GDS versions 9.0 R2, 9.5, 10.0 CVSS 3.0CRITICAL 9.1
- TI-2023-03234 GE Digital CIMPLICITY Heap-based Buffer Overflow CVSS 3.1CRITICAL 9.8
- TI-2022-02853 GE CIMPLICITY Out-of-bounds Write CVSS 3.1HIGH 7.8
- TI-2022-02845 GE CIMPLICITY Access of Uninitialized Pointer CVSS 3.1HIGH 7.8
- TI-2022-02729 GE CIMPLICITY Access of Uninitialized Pointer CVSS 3.1HIGH 7.8
Sources
- CVE-2020-6992 · CVE Program
- CVE-2020-6992 · NVD
- FIRST EPSS
- GHSA-xw2r-q7pv-2r5q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences