Read the docs
TI-2020-05968 Aliases CVE-2020-7385GHSA-xgww-h98f-24qf

Metasploit Framework 'drb_remote_codeexec' code execution

Priority MEDIUM 42CWE-502Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.

Summary

By launching the drb_remote_codeexec exploit, a Metasploit Framework user will inadvertently expose Metasploit to the same deserialization issue that is exploited by that module, due to the reliance on the vulnerable Distributed Ruby class functions. Since Metasploit Framework typically runs with elevated privileges, this can lead to a system compromise on the Metasploit workstation. Note that an attacker would have to lie in wait and entice the Metasploit user to run the affected module against a malicious endpoint in a "hack-back" type of attack. Metasploit is only vulnerable when the drb_remote_codeexec module is running. In most cases, this cannot happen automatically.

Why it matters now

EPSS 0.0175 77th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed metasploit-framework (RubyGems): 4.19.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Rapid7Metasploit Framework6.0.15 – 6.0.15—No fix listedCNA
—metasploit-framework (RubyGems)before 4.19.04.19.0Patch availableGHSA-xgww-h98f-24qf
  • Metasploit Framework VendorRapid7 Affected 6.0.15 – 6.0.15 Fixed in — No fix listed CNA
  • metasploit-framework (RubyGems) Vendor— Affected before 4.19.0 Fixed in 4.19.0 Patch available GHSA-xgww-h98f-24qf

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:rapid7:metasploit:*:*:*:*:*:*:*:*before 4.19.0VulnerableRapid7
  • cpe:2.3:a:rapid7:metasploit:*:*:*:*:*:*:*:* Versions before 4.19.0 Vulnerable ·Rapid7

Remediation

  • Fix · GHSA-xgww-h98f-24qf metasploit-framework (RubyGems) Fixed in 4.19.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-7385
  2. 2026-10-03 Alias added: GHSA-xgww-h98f-24qf

References

  • TI-2019-04008 Rapid7 Metasploit HTTP Handler Denial of Service CVSS 3.1HIGH 7.5
  • TI-2020-05967 Client-Side Command Injection in Rapid7 Metasploit CVSS 3.1HIGH 7.8
  • TI-2020-05961 Rapid7 Metasploit Framework Relative Path Traversal in enum_osx module CVSS 3.1CRITICAL 9.8
  • TI-2020-05944 Metasploit Framework Plugin Libnotify Command Injection CVSS 3.1HIGH 7.8
  • TI-2020-05962 Rapid7 Metasploit Framework Relative Path Traversal in telpho10_credential_dump module CVSS 3.1HIGH 8.1
  • TI-2019-03989 Rapid7 Metasploit Framework Zip Import Directory Traversal CVSS 3.1HIGH 7.3
See all 16 →

Sources