Sage X3 Syracuse Missing Authentication for Critical Function in Developer Environment
Priority LOW 36CWE-306Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass, Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-306 and CWE-78.
Summary
Sage X3 System CHAINE Variable Script Command Injection. An authenticated user with developer access can pass OS commands via this variable used by the web application. Note, this developer configuration should not be deployed in production.
Why it matters now
EPSS 0.02071 81st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed X3 (Sage): Syracuse 9.22.7.2, Syracuse 11.25.2.6, Syracuse 12.10.2.8
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Sage | X3 | V9 to before Syracuse 9.22.7.2; V11 to before Syracuse 11.25.2.6; V12 to before Syracuse 12.10.2.8 | Syracuse 9.22.7.2, Syracuse 11.25.2.6, Syracuse 12.10.2.8 | Patch available | CNA |
- X3 VendorSage Affected V9 to before Syracuse 9.22.7.2; V11 to before Syracuse 11.25.2.6; V12 to before Syracuse 12.10.2.8 Fixed in Syracuse 9.22.7.2, Syracuse 11.25.2.6, Syracuse 12.10.2.8 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sage:syracuse:*:*:*:*:*:*:*:* | 9.0 to before 9.22.7.2 | Vulnerable | Sage |
| cpe:2.3:a:sage:x3:9.0:*:*:*:*:*:*:* | 9.0 | Running on | Sage |
| cpe:2.3:a:sage:syracuse:*:*:*:*:*:*:*:* | 11.0 to before 11.25.2.6 | Vulnerable | Sage |
| cpe:2.3:a:sage:x3:11.0:*:*:*:*:*:*:* | 11.0 | Running on | Sage |
| cpe:2.3:a:sage:syracuse:*:*:*:*:*:*:*:* | 12.0 to before 12.10.2.8 | Vulnerable | Sage |
| cpe:2.3:a:sage:x3:12.0:*:*:*:*:*:*:* | 12.0 | Running on | Sage |
- cpe:2.3:a:sage:syracuse:*:*:*:*:*:*:*:* Versions 9.0 to before 9.22.7.2 Vulnerable ·Sage
- cpe:2.3:a:sage:x3:9.0:*:*:*:*:*:*:* Versions 9.0 Running on ·Sage
- cpe:2.3:a:sage:syracuse:*:*:*:*:*:*:*:* Versions 11.0 to before 11.25.2.6 Vulnerable ·Sage
- cpe:2.3:a:sage:x3:11.0:*:*:*:*:*:*:* Versions 11.0 Running on ·Sage
- cpe:2.3:a:sage:syracuse:*:*:*:*:*:*:*:* Versions 12.0 to before 12.10.2.8 Vulnerable ·Sage
- cpe:2.3:a:sage:x3:12.0:*:*:*:*:*:*:* Versions 12.0 Running on ·Sage
Remediation
- Fix · CNA X3 (Sage) Fixed in Syracuse 9.22.7.2, Syracuse 11.25.2.6, Syracuse 12.10.2.8
Timeline
- 2026-10-02 Threatist record created from CVE-2020-7389
- 2026-10-03 Alias added: GHSA-639w-2r2j-2x43
References
More Sage Syracuse vulnerabilities
- TI-2020-05972 Sage X3 Syracuse Persistent XSS in Edit User page CVSS 3.1MEDIUM 5.4
Sources
- CVE-2020-7389 · CVE Program
- CVE-2020-7389 · NVD
- FIRST EPSS
- GHSA-639w-2r2j-2x43 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences