Codecov npm module before 3.6.2 allows remote attackers to execute arbitrary commands via the "gcov-args" argument.
Priority MEDIUM 42CWE-78Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
Codecov npm module before 3.6.2 allows remote attackers to execute arbitrary commands via the "gcov-args" argument.
Why it matters now
EPSS 0.01859 79th percentileScored 2026-11-07
Fix Fixed codecov (npm): 3.6.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | codecov npm module | All versions prior to version 3.6.2 | — | No fix listed | CNA |
| — | codecov (npm) | before 3.6.2 | 3.6.2 | Patch available | GHSA-mh2h-6j8q-x246 |
- codecov npm module Vendor— Affected All versions prior to version 3.6.2 Fixed in — No fix listed CNA
- codecov (npm) Vendor— Affected before 3.6.2 Fixed in 3.6.2 Patch available GHSA-mh2h-6j8q-x246
Remediation
- Fix · GHSA-mh2h-6j8q-x246 codecov (npm) Fixed in 3.6.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-7596
- 2026-10-03 Alias added: GHSA-mh2h-6j8q-x246
References
Sources
- CVE-2020-7596 · CVE Program
- CVE-2020-7596 · NVD
- FIRST EPSS
- GHSA-mh2h-6j8q-x246 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences