netius prior to 1.17.58 is vulnerable to HTTP Request Smuggling.
Priority LOW 29CWE-444Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
netius prior to 1.17.58 is vulnerable to HTTP Request Smuggling. HTTP pipelining issues and request smuggling attacks might be possible due to incorrect Transfer encoding header parsing which could allow for CL:TE or TE:TE attacks.
Why it matters now
EPSS 0.00839 58th percentileScored 2026-11-07
Fix Fixed netius: 1.17.58netius (PyPI): 1.17.58
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | netius | before 1.17.58 | 1.17.58 | Patch available | CNA |
| — | netius (PyPI) | before 1.17.58 | 1.17.58 | Patch available | GHSA-wm2m-xrrp-j74c |
- netius Vendor— Affected before 1.17.58 Fixed in 1.17.58 Patch available CNA
- netius (PyPI) Vendor— Affected before 1.17.58 Fixed in 1.17.58 Patch available GHSA-wm2m-xrrp-j74c
Remediation
- Fix · CNA netius Fixed in 1.17.58
- Fix · GHSA-wm2m-xrrp-j74c netius (PyPI) Fixed in 1.17.58 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-7655
- 2026-10-03 Alias added: GHSA-wm2m-xrrp-j74c
References
Advisory 2
Sources
- CVE-2020-7655 · CVE Program
- CVE-2020-7655 · NVD
- FIRST EPSS
- GHSA-wm2m-xrrp-j74c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences