Arbitrary code execution in grunt
Priority LOW 36CWE-1188Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
The package grunt before 1.3.0 are vulnerable to Arbitrary Code Execution due to the default usage of the function load() instead of its secure replacement safeLoad() of the package js-yaml inside grunt.file.readYAML.
Why it matters now
EPSS 0.02304 83rd percentileScored 2026-11-07
Fix Fixed grunt: 1.3.0grunt (npm): 1.3.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | grunt | before 1.3.0 | 1.3.0 | Patch available | CNA |
| — | grunt (npm) | before 1.3.0 | 1.3.0 | Patch available | GHSA-m5pj-vjjf-4m3h |
- grunt Vendor— Affected before 1.3.0 Fixed in 1.3.0 Patch available CNA
- grunt (npm) Vendor— Affected before 1.3.0 Fixed in 1.3.0 Patch available GHSA-m5pj-vjjf-4m3h
Remediation
- Fix · CNA grunt Fixed in 1.3.0
- Fix · GHSA-m5pj-vjjf-4m3h grunt (npm) Fixed in 1.3.0 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2020-7729
- 2026-10-03 Alias added: GHSA-m5pj-vjjf-4m3h
References
Advisory 3
Sources
- CVE-2020-7729 · CVE Program
- CVE-2020-7729 · NVD
- FIRST EPSS
- GHSA-m5pj-vjjf-4m3h · GitHub Advisory Database · CC BY 4.0
- CVE-2020-7729 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences